Strange Unibody MacBook Optical Drive Behavior

Discussion in 'MacBook' started by gibbz, Dec 13, 2008.

  1. gibbz macrumors 68030

    Joined:
    May 31, 2007
    #1
    I have a new unibody MacBook. I recently discovered odd behavior from the SuperDrive. I had successfully ripped quite a few discs, importing music into iTunes, when I tried to insert Three Days Grace self-titled album. The SuperDrive made some weird clunking noises and proceeded to eject the disc after roughly 10-15 seconds.

    I thought that the CD was messed up, so I tried it in my older MacBook Pro, and to my surprise, it read it just fine. I tried other CDs and the new MacBook worked just fine. I finally got to importing AC/DC Back in Black, and again, the SuperDrive made the same weird noises and ejected. However, it worked in the old MacBook Pro though. This occurred for a select group of other CDs, but not all.

    I took the MacBook to a "Genius" today to see about getting the drive replaced. I was able to replicate the problem for him. He took the CD and it worked in an older MacBook, but then he tried it in 4 unibody MacBooks and all ejected the discs.

    He said that since they would have just replaced it with the same optical drive, that it would pointless since all of the new ones were spitting the discs out. He instead sent in a report to engineering to see if they could figure things out.

    Anyone have issues like this? I find it very weird that most CDs worked but some consistently did not, yet would work in older MacBooks. This seems to point to some problem in the new MacBooks or something.
     
  2. HSE Guest

    Joined:
    Oct 18, 2008
    #2
    Which optical drive do you have? They're using two different versions for the new MacBook.
     
  3. Mr Black macrumors member

    Mr Black

    Joined:
    Sep 6, 2007
    Location:
    Ontario, Canada
    #3
    Wow, I just started getting this exact same issue with the optical drive last night. I've got a mid 2007 white macbook. The model of my optical drive = MATSHITA DVD-R UJ-857E
     
  4. gibbz thread starter macrumors 68030

    Joined:
    May 31, 2007
  5. Bloake macrumors 6502

    Bloake

    Joined:
    Dec 2, 2008
    #5
    I can't help giggling at the fact that the brand name has the word 'sh*t' in it.
     
  6. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #6
    The drives are not all the same in the new unibodies.

    I've had three now and one had a Sony superdrive.
     
  7. treetop682 macrumors newbie

    Joined:
    Oct 14, 2008
    #7
    Weird noises too

    My superdrive is making weird noises when my macbook pro unibody comes out of sleep. It sounds like it trying to suck in or eject an imaginary disk. Does this sound familiar to you?
     
  8. antikryst macrumors newbie

    Joined:
    Mar 1, 2006
    #8
    my unibody macbook spits ALL discs out. dvd movie, blank cd, blank dvd, even the apple software discs. i cant get anything to mount.

    is this a firmware/software problem? or a hardware problem? apple support says the drive needs replacing but i dont want anyone to open up my almost new macbook unless it is really necessary.

    drive is MATSHITA DVD-R UJ-868

    im also running all latest patches from the software update
     
  9. tubbymac macrumors 65816

    tubbymac

    Joined:
    Nov 6, 2008
    #9
    This is disturbing but normal behavior. Sounds like it's coughing up a furball when it wakes from sleep.
     
  10. antikryst macrumors newbie

    Joined:
    Mar 1, 2006
    #10
    this is SOOOO FRUSTRATING. im in manila and i havnt slept trying to get this resolved. i was up til 3am (3pm EST with apple support).

    is it just me? is anyone having a problem with the drive EJECTING ALL discs?
     
  11. gibbz thread starter macrumors 68030

    Joined:
    May 31, 2007
    #11
    Mine will still read some discs, but I have found even more discs that it spits out. This is frustrating because if they simply replace it with the same faulty drive, what is the point. Sounds like they need a new drive altogether.
     
  12. Egypt Urnash macrumors newbie

    Joined:
    Dec 22, 2008
    Location:
    Boston, MA
    #12
    I've been getting this too. About 50% of the time when I stick a CD in it makes weird noises and spits it back out; the other half of the time it works as expected. Reinserting the same CD will usually work after a few times. I needed to burn a couple of DVDs yesterday and the drive was exceedingly finicky; at one point it threw up an error about "cannot calibrate laser strength for inserted media" or something like that.

    I am wondering if this is a consequence of the recent software update, as I had burnt a CD full of data with no problems beforehand.

    No problems ejecting.

    MATSHITA DVD-R UJ-868 here, OS 10.5.6.
     
  13. antikryst macrumors newbie

    Joined:
    Mar 1, 2006
    #13
    good for you... it works sometimes. my superdrive doesnt work at all :(
     
  14. jaredtomas macrumors regular

    jaredtomas

    Joined:
    Aug 11, 2008
    Location:
    Australia
  15. javierbds macrumors regular

    Joined:
    Sep 12, 2005
    Location:
    Madrid, Spain
    #15
    Air´s external drive should work with all Apple computers

    This is why many of us want only external drives (or non pro boxes, easy replaceable parts) ... Mine has been dead (late 2006 iMac) for years and I have been very happy with my external Samsung drive for even more years. My iBook drive from early 2005 still works ...
     
  16. MrRage macrumors member

    Joined:
    Jun 14, 2008
    #16
    I had the same issue with some DVD with my first MacBook. I had it for 3 days so I took it back and the place I got it from replaced the unit with one from a different batch, unit worked no issues sense.

    It was odd because the application DVD that came with the macbook was one of the ones it could not read.. but it could read the install.
     
  17. kale39 macrumors newbie

    Joined:
    Jan 21, 2009
    #17
    Me too!

    I'm also not getting it to read any CDs. I burned a program onto a CD using this very drive, and now I can't get it to read it so that I can uninstall the software. Does anybody know how you update the software? Is there any other fix than getting a new drive? It seems if we're all having this problem across a whole bunch of different drives then the problem is probably software related.

    Matshita CW-8221
     
  18. ThePersian macrumors newbie

    Joined:
    Feb 7, 2009
    #18
    I have the same problem

    I see many of you have the problem with the Mashita drive, but I have the same problem with the HL-DT-ST DVDRW GS21N drive.

    My new unibody Macbook is not even a week old, and when I tried so insert a blank DVD-R, it could not read it, and after 10 seconds or so my mac ejected it. It's not the DVD's, because the DVD's works fine on my White Macbook but not on my unibody Macbook. I've read that some mac-users have the same problem and have tried to clean the optical drive with some sort of cleaning cd, and that has fixed their problem. I'll guess I would try that as a start, and if no luck, I would have to send it in for a replacement or whatever. It's sad when the mac is all new, and not even a week old. But I don't think it's a hardware issue, but I don't really know. Anyone with the same problem, that doesn't have the Mashita drive?

    Here is my info:

    HL-DT-ST DVDRW GS21N:

    Firmware Revision: SA15
    Interconnect: ATAPI
    Burn Support: Yes (Apple Shipping Drive)
    Cache: 2048 KB
    Reads DVD: Yes
    CD-Write: -R, -RW
    DVD-Write: -R, -R DL, -RW, +R, +R DL, +RW
    Write Strategies: CD-TAO, CD-SAO, CD-Raw, DVD-DAO
    Media: Insert media and refresh to show available burn speeds
     
  19. danoan522 macrumors newbie

    Joined:
    Jan 10, 2009
    Location:
    Saint Lucia
    #19
    same here

    same problem here; this is embarrassing to have a spanking, brand new macbook pro (unibody) that does not function well in the presence of your friends. Now i have to look for excuses when someone asks me to burn a cd for them, or gives me a cd to insert in the first place. Every single disc the mbp spits out is read effortlessly by my imac. WTH is going on here? discs of all types and colors go out just as they go in, in the span of a few seconds. Frustrating?
     
  20. TonyL08 macrumors regular

    Joined:
    Sep 25, 2007
    #20
    Glad to see this thread as I'm having the exact same problem. Brand new white MacBook with the new nvidia chipset. Some of my burnt DVDs will not read in this machine even though they read in all of my other computers.

    I took it to an Apple store where the genius fed it about 10 discs, all of which read just fine. We took my non-working disc to the table of new MacBooks and tested four. None of which worked.

    The discs are from the same spool, burned on the same computer with the same drive within hours or days of each other. Of the 5 or so I need to copy onto the new machine, two would not read and the rest worked just fine. All 5 read in all of my other computers.

    System Profiler reports my drive as: HL-DT-ST DVDRW GS22N
     
  21. hjprado macrumors newbie

    Joined:
    Mar 7, 2009
    Location:
    Santa Monica, CA
    #21
    ello,
    I have the same issue with a brand new macbook pro 15" unibody, My unit reads perfectly all DL disks but the DVD+R DL recorded on another computer are just spitted out about 10 or 15 seconds after inerting it.
    I've tryed several solutions and none seem to work:
    Reseted the SMC
    Hardware test: all OK
    When it detects a blank DVD+R DL I try to record the dmg and stops sayinf error: 0x80020022
    Tryed repair disk permissions with the leopard install DVD, and I get a "The underlying task reported failure on exit"
    I've been calling apple, but today inEurope apple service is closed, so I'll have to wait untill monday...when i get my response I'll post it to see if i helps any of you guys...
     
  22. Weird phobias macrumors newbie

    Joined:
    Mar 14, 2009
    #22
    Weird phobias

    Weird phobias that control your life.....: The humongous list of phobias that you can have find anywhere shares the same characteristics, like the fear of dentist or doctor. Phobias and Fears are emotional reactions to an uncomfortable situation that causes physical and mental responses. Some of the symptoms that affect all of these weird phobias and fears like fear of success or fear of long words include:

    1) Horror, terror, confusion, fear and uncontrollable feelings of panic.

    2) Unawareness that phobias and fears go beyond.

    3) Acceleration of heart beat, extreme sweating, trembling, breathing problems.
     
  23. dbwie macrumors 6502

    Joined:
    Jun 11, 2007
    Location:
    Albuquerque, NM, USA
    #23
    MacBook

    I have the UJ-868 drive in my new MacBook. It spits out a Leopard install DVD repeatedly when I try to boot from it, but not when I insert it while logged into my main account. I have not had any issues yet with other CDs, or DVDs, yet (crossing fingers).
     
  24. dmswany macrumors newbie

    Joined:
    May 20, 2009
    #24
    same problem, seems fixed with an SMC reset

    Hi all, I was having similar problems with my unibody 17" (superdrive model HL-DT-ST DVDRW GS21N). I had terrible grinding noises and no DVD-Rs would mount. Finally, one did and it read for a little while, but it ended up wearing a groove in the disk!

    Reading this thread, I called Apple Care, expecting to get a new drive. The nice lady (Kim) asked me to do an SMC reset, which I didn't think would fix it (and she really didn't either...)

    But, strangely, it seems it did!

    I held left (shift,control,option) and the power button, waited 5 seconds, and pushed the power button. (see http://support.apple.com/kb/HT1411 )
     

Share This Page