Strange URL Issues...Network, not computer...

Discussion in 'Mac Basics and Help' started by hellodon, Mar 11, 2010.

  1. hellodon macrumors 6502

    Jan 19, 2006
    I'm hoping someone here can help me out with's the strangest problem.

    I go to the message board "" pretty regularly and this seems to be the only site that I have seen problems with.

    Twice in the past 8 months I could load up the main page, but when I clicked to enter the site, it took me to I even tried googling one of the forums specifically and entering that way and it was the same thing, but a different page on I brought this up on the forum and NO ONE else has ever had this happen. They thought I was crazy and assumed I had a virus....when I saw it I assumed the site was temporarily hacked.

    Today, same site, similar issue. I can load the main page and then when I click to enter it takes me to an Invalid URL screen that says:

    That number changes each time I try or if I refresh. Googling that reference number brings nothing up.

    Now - at first I thought that this may be some sort of attack on my computer, a mac virus of some sort...but it can't be. It does it on every computer on my network including my iPhone. I used the iPhone to test on wifi and got the same error page. When I turned off wifi and switched to 3G, it loaded the site fine.

    So something is going on, and I am assuming it has to do with either my wireless router or Time Warner Cable but I've never heard of anything like this.

    I don't see any issues with any other websites...just that one.

    Anyone have any ideas for me?

    I assume in an hour, it'll be fine...because that's what happened the other times I've seen this problem - the site loads fine in a little while - but it doesnt make sense and honestly I'm a bit worried that my network may not be secure.

    Any help would be greatly appreciated
  2. techound1 macrumors 68000


    Mar 3, 2006
    Sounds like the DNS your home router is using (most likely the one from your ISP) is buggered up. Try changing your DNS to openDNS (see

Share This Page