Strange Usage Stats Problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iRabbit, Jul 10, 2007.

  1. iRabbit macrumors 6502

    Joined:
    Jul 10, 2007
    #1
    Yes, I'm getting the dreaded "--" showing for my usage stats.

    I've tried restoring from a full charge.
    I've tried restoring from a low charge.
    I've tried the dock and the AC Power adaptor.
    I've tried taking it off the dock when it's fully charged and putting it on the AD adaptor.
    I've tried doing a hard reset after a full charge.
    I've tried letting the battery run dead and THEN charging it.
    I've tried charging with the power off and in Airplane mode.
    I always charge with WiFi and BT off.

    No matter WHAT I can't get usage stats to show anything other than "--".

    Now today, I read an article that said the battery should "glow" when it's fully charged (and still on the charger)... look at the iPhone all the way on the right...

    [​IMG]

    a closeup...

    [​IMG]

    So, since I"m pretty sure my battery has never "glowed" I called up Apple. First tech support person wasn't sure and talked to me about all the other things I've tried. Then she escalated me to a "product specialist". He didn't know either. I shared the article with him. He put me on hold to talk to a supervisor who suggested I run the battery to dead and then charge. I told him I'd done that already. He put me on hold to talk to "the engineers". Came back and told me "yes.. the battery should 'glow' when it's fully charged, but it doesn't HAVE to... if that makes sense..." LOL! He told me he'd have a engineer call me back in a day or so.

    Now, ultimately, none of this is a huge deal since I'm getting VERY good battery life. As long as I keep WiFi off other than when I need it, I can go two days before I need my battery to be charge. The Apple product specialist and "the engineers" seem to think that the software isn't recognizing the fully charged battery properly.

    I'm reluctant to return it since I have NO OTHER ISSUES whatsoever.

    Thoughts?
     
  2. ejuanpiman macrumors member

    Joined:
    Jun 6, 2007
    #3
    To me it seems as if the last phone has the display BRIGHTER than the others...
     
  3. iRabbit thread starter macrumors 6502

    Joined:
    Jul 10, 2007
    #4
    Look again. If you look closely you'll notice that, besides the glow, the green is filling the battery ALL THE WAY, unlike the 2 on the left. The one on the furthest right has NO GAP from green to the end of the battery.

    I started a poll on another site, and about 1/2 the people who've responded agree that there battery "glows" when fully charged. Plus... read what I said... Apple confirmed it as well.
     
  4. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #5
    It certainly does glow when fully charged. I noticed that on the first day. At first I though I was just seeing something, but now its clear it does. Its very subtle.
     
  5. ejuanpiman macrumors member

    Joined:
    Jun 6, 2007
    #6
    I do see what you say about the level being fuller on the last one. I had seen that after I posted. Anyways I will check tonight when I set mine to charge again. Right now as I stand I have 80% battery left and I have 2 hours 17 minutes on usage and 7 hours 36 minutes on standby. This is with Wifi on and email checking every 15 minutes. Most of the usage time has been on phone calls, and I have watched one youtube video and a couple of txt messages. I dont know if that seems ok.
     
  6. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #7
    The one on the left is at 95% charger, the right is full. Yellow lines I added help show that - I hope.

    [​IMG]
     
  7. iRabbit thread starter macrumors 6502

    Joined:
    Jul 10, 2007
    #8
    I know it's hard to see, but if you look at the other photo, with the 3 iphones, it LOOKS at thought the power chord icon is reporting "full" on all three... this is what I have experienced on my own phone. No glow, but the power chord icon comes on in the mini-battery.

    Like I said, otherwise I'm getting good battery life... I'm starting to think that a percentage of us may have the same issue, and it really IS a software problem.
     
  8. lilnyc macrumors 6502a

    lilnyc

    Joined:
    Jun 5, 2007
    #9
    I just keep my iPhone plugged in so I don't understand battery issues. I use it at the gym, then plug it up afterward while getting ready for work. At work I leave it charging also - no big deal.
     
  9. NightStorm macrumors 68000

    Joined:
    Jan 26, 2006
    Location:
    Whitehouse, OH
    #10
    I'm in the same boat as you and went through pretty much the same things... was escalated to a product specialist who, after talking to me for 10 minutes or so stated that while the phone seems to be working alright, it would probably be a good idea to return it to Apple. He gave me the choice of taking it to an Apple Store (there aren't any in my area), or returning it to them via FedEx. While I'm scared to do so (since it is working very well), I think I am going to go ahead and return it and hope the replacement has no issues with it.

    I will say that Apple's tech support has once again made me happy to buy their products; very knowledgeable, friendly, and I can understand what they are saying.

    I think I am going to order another dock for my office so I can leave it on there when I'm not using it. The lineout will come in handy too...
     
  10. Cybergypsy macrumors 68040

    Cybergypsy

    Joined:
    May 16, 2006
    Location:
    Central Florida!
    #11
    Had the same issue with my sons phone...apple genus said while on chargerdo a reset hold power and home button down while on charger...i drove to apple 120 miles and returned the phone and got a brand new 8G for my son :) but the info worked on y old phone...so worth a try :)
     
  11. iRabbit thread starter macrumors 6502

    Joined:
    Jul 10, 2007
    #12
    LOL, yeah but that's not a realistic solution. There are times I'm away from a power source for quite a long time and I'm not willing to carry a generator around with me :p

    My issue isn't that I'm getting crappy battery life. My battery life is actually very good. I'm going about 2 days without needing to charge, which gives me confidence that even with fairly heavy use I'd get at least a day out of it if necessary.

    What I'm trying to pin down here is if there is indeed an issue with the way the software reports the battery being fully charged. It appears there are two groups of people with battery problems... those that can't really hold a charge for a long time (a smaller group of people I believe) and those who seem to have a software glitch where the battery being fully charged isn't properly reported (but they get good battery life). Obviously, one requires the unit to be replaced, the other could be fixed through firmware.
     

Share This Page