Strange USB issue.

Discussion in 'Mac Pro' started by c073186, Aug 5, 2008.

  1. c073186 macrumors 6502a

    Joined:
    Nov 2, 2007
    #1
    All of a sudden a few days ago, I realized that my keyboard was not working. It was plugged into my 23" ACD. So I unplugged it and put it into my Mac Pro. It worked. So I decided that my ACD's USB ports were not working. A phone call to AppleCare and he told me to take the display for repair to the Apple Store. I just did that, and the USB's worked fine in the store. I take it home, still does not work. So I thought my USB ports on my Mac Pro must be bad. But everything else I plug into all three of the back ones works just fine; but my ACD does not. In the store, he used all of my own cables / power adapter.

    What the heck? Why is my USB not working for my ACD but it is for everything else?
     
  2. byocrysis macrumors regular

    byocrysis

    Joined:
    Nov 10, 2007
    Location:
    San Luis Obispo, CA
    #2
    I had the same problem but it was with a printer being plugged into my ACD USB port. I read around online and found out that sometimes clearing the NVRAM and PRAM fixes the problem. To do this shut down the computer. Then when you turn it on hold down command+option+p+r. After you hold this down for like 10 sec. your computer will gong again (the startup noise) and you can let go. Fixed the problem for me and hopefully will for you too.
     
  3. c073186 thread starter macrumors 6502a

    Joined:
    Nov 2, 2007
    #3
    Thank you very much; that worked. I just wish I would have done that BEFORE going to the Apple Store and having them mess with my $900 monitor...
     
  4. c073186 thread starter macrumors 6502a

    Joined:
    Nov 2, 2007
    #4
    It looks like I spoke too soon: resetting the PRAM and NVRAM did fix it; but only temporarily. The problem is back now, and resetting those is not fixing it this time. Any other ideas?
     

Share This Page