Strange, Very Strange Trackpad Issue

Discussion in 'MacBook Air' started by dml, Mar 22, 2012.

  1. dml macrumors newbie

    Feb 12, 2008
    Just bought a MacBook Air. 5 days later, a very strange problem with the trackpad surfaces. It won't allow me to "click" anything anymore. Weirdly, most of the other functions are still working properly :

    - Scrolling still works;
    - Two finger tap sill brings up a contextual menu;
    - Gestures work fine.

    Everything works, except the single most important function : clicking!!! Neither clicking nor single finger tapping will work.

    I tried plugging in a wired Apple mouse. To no avail : I can control the cursor, but clicking won't work!

    I also tried resetting the System Management Controller (SMC), as well as the PRAM and NVRAM. Didn't help either.

    Anyone has an idea as to how I might resolve such an issue?

    Thanks in advance for your help!
  2. Geo411m macrumors regular

    Apr 3, 2010
    Check the click speed. I saw this happen before and the click speed was too high so no one was able to click fast enough.
  3. dml thread starter macrumors newbie

    Feb 12, 2008
    Do you mean the "double-click" speed? I checked it and it seems normal. But in my case, even the single-click won't work...
  4. Geo411m macrumors regular

    Apr 3, 2010
    Yeah, that's the setting. In my job we had the same problem at that turned out to be the problem. Not really sure what's your issue. If I were you I would return it back to the store since it's 5 days old. For that amount of money, it should be working flawlessly.
  5. VMSwizard411 macrumors newbie

    Dec 12, 2010
    Charlotte, NC USA
    sounds so familiar! :)

    You should check out this thread to see if it's the same issue that I recently had, and resolved by following the suggestion to press-n-hold the trackpad's "button" firmly.
  6. dml thread starter macrumors newbie

    Feb 12, 2008
    I did take a look at that thread, and it doesn't seem to be the same issue. As I said earlier, the problem persists even if I plug a mouse in the computer! I can control the cursor (as is the case with the trackpad), but I can't select or double-click anything. Strangely enough, the pointer will not highlight anything in a contextual menu, nor in the top bar...

    All of this makes me think this is a software issue, not a hardware one...

    Thanks anyway for the suggestion!

    I think the next step will be to bring the computer back to the store...
  7. VMSwizard411 macrumors newbie

    Dec 12, 2010
    Charlotte, NC USA
    Certainly with such a new unit I'd probably do the same: make it Apple's "problem", not your own in case there are other gremlins inside that are waiting to show up.

    With my symptoms being identical to you that even external mice couldn't click I was floored when the problem ended up being so easily worked around in my case (with a long out-of-warranty MBP). I kept going back and forth trying to diagnose and decide: hardware or software. The external mouse failures certainly pointed to software more, but I believe ultimately it was that the main trackpad was causing the system to think a click to already in play... even though I wasn't doing any clicking so the external click was being skipped as well.

    The main thing is to enjoy your computer! :)
  8. dml thread starter macrumors newbie

    Feb 12, 2008
    Problem solved (kind of)

    I brought back the computer to the store, to have it checked.

    Since they couldn't really understand what was causing the problem (software or hardware?), they simply replaced the computer.

    Hopefully, this one will last longer than five days!
  9. iTrubes macrumors newbie

    Sep 15, 2008
    Tamworth, UK
    I had this same problem. Everything was working fine except single click, the scrolling would work and so would gestures. I did however find the problem. It may not have been the same issue as yourself. I had a bluetooth magic mouse connected to it, that I forgot to turn off. This was in a drawer with something resting on it, holding the mouse click down. As soon rectified this, all back to normal. :)

    So perhaps it was a Bluetooth device causing the problem for yourself also. But probably not, just me being a douche.
  10. Acorn macrumors 68020


    Jan 2, 2009
    I currently have this same issue but it comes and goes. suddenly everything works on the trackpad except right and left click. its happened maybe twice in 2 weeks. a reboot seems to fix it. i dont know what the cause is.

    i do not use bluetooth on this device. in fact its turned off.
  11. YoshioDuo macrumors newbie

    Oct 9, 2013
    Thank you... Thank you.

    This has been driving me crazy for DAYS. I've looked all over the internet but it was a hard issue to search for. My right-click, gestures, etc all worked, just no single clicking! I had the soft click enabled but neither soft or actual click-clicking didn't work.

    Lo and behold, my Bluetooth magic mouse shoved in my backpack from the beginning of the week had still been on and connected. It was pressed down from other things in my backpack. Soon as I pulled it out, everything was back to normal!

    Unbelievable. iTrubes, thank you for sharing your crazy experience that I just shared in. I signed up for this site just to post this and will likely never post again haha.
  12. DisplacedMic macrumors 65816

    May 1, 2009
    i was just about to post an almost identical story.

    OP I know you returned your computer already and since they couldn't figure it out in the store this obviously wasn't your exact issue, but for me occasionally I notice that if i connect to a BT mouse (the magic trackpad in my case) the click feature on the air's trackpad sometimes stops working. VERY frustrating.

    the first time it happened i had no clue what was going on. i wasn't too worried about it so i just forced a reboot. but it persisted! eventually i had to shut it down with a terminal command and then it fixed it. i forgot about it until it happened again - that's when i figured out it was the BT trackpad.

    it only happens occasionally (in my case 2-3 times) so i'm glad it's not something i have to remember to worry about every time i connect to my TBD or walk in and out of range of my wireless peripherals.
  13. TrevoseKid macrumors newbie

    May 1, 2011
    The BT Related Advice Worked ...

    Hi! Many thanks to the posters here! My trackpad single click stopped working and everything I tried failed. It turned out my MacBook had connected to my Mac Mini (in my office about 10 feet away from where I use my MacBook), and the single click stopped working (via external USB mouse, too). My BT is usually OFF, but I turned it on recently to use BT head-phones at a coffee shop! As soon as I shut BT down on my MacBook - all was well! Thanks MACRUMORS! :D

Share This Page