Strange Visual Voicemail Issue

Discussion in 'iPhone Tips, Help and Troubleshooting' started by macslayer118, Jul 10, 2009.

  1. macslayer118 macrumors 6502

    Joined:
    Oct 6, 2008
    Location:
    Dallas, TX
    #1
    I hope someone can help me out. I searched but did not see this specific voicemail problem.

    Recently, my voicemails do not show up unless I do a hard reset on my iPhone. Simply turning it off and back on does not work.

    I had a message from July 2nd that I didnt recieve until I reset my phone on the 4th. It still says it came in on Thursday, it just didnt appear until it booted back up.

    I just got off the phone with AT&T and they reset my data plan and voicemail plan, but it's still happening. I wanted to check on here before calling them back.

    Hope someone can help! :D
     
  2. macslayer118 thread starter macrumors 6502

    Joined:
    Oct 6, 2008
    Location:
    Dallas, TX
    #2
    Ok, so I just wanted to update, just in case someone else has the same issue. I called AT&T, and they had me call 1-800-My-iPhone since resetting the voicemail didn't work.

    They told me the only was to fix the issue was a "Restore as new". Apparently it's a known issue with 3.0


    Great.

    I might restore, I might not. Oh well :rolleyes:
     
  3. iLoveiPhone3GS macrumors member

    Joined:
    Jun 26, 2009
    #3
    Well if they suggest restoring...then restore! I find that a quick restore solves 90% of my software problems. Its really not that hard and takes hardly any time at all. When your phone gets done restoring, just check the "set up as new iPhone" option. Its either try a restore and have the problem fixed or do a hard reset and go through a bunch of crap to get your messages.

    If for some reason the restore doesnt work, I'd swing by an ATT store for a replacement SIM.
     

Share This Page