Strange wifi issue. Can't connect to non apple

Discussion in 'MacBook Air' started by Buffrey007, Jun 2, 2017.

  1. Buffrey007 macrumors newbie

    Buffrey007

    Joined:
    Jun 2, 2017
    #1
    My MacBook Air (about 4 years old) has started to not connect to public and private wifi which isn't ran by an apple extreme. I say this because my home and the Apple Store it works fine but at other people's houses or free wifi places it doesn't.

    Does anyone have any ideas?

    Running laterst OSX and have tried a couple things With the DNS but I'm not mega techy but am decent enough.

    It's hard to test though as it works at home so any changes I make I need to be somewhere else to be sure.
     
  2. Stefan johansson macrumors 65816

    Stefan johansson

    Joined:
    Apr 13, 2017
    Location:
    Sweden
  3. kohlson macrumors 6502a

    Joined:
    Apr 23, 2010
    #3
    You public library may be a good place to help diagnose.
    It may be that your home network is set up with static IP configuration. In my experience, a little unusual. Try:
    - Network Prefs - select wi-fi
    - Advanced - TCP/IP tab: Configure IPv4 -> DHCP; IPv6 (automatically)

    Renew DHCP lease

    All config settings are pulled from the router using DHCP. This includes address, subnet mask, DNS, etc.

    Note that I've seen cases where a reboot may be required.

    If I had to guess at what's going on, if you're fiddling with manual settings, then the MBA has been hard configured to an unacceptable subnet. Example: your setting is 192.168.1.X, and many public places are configured for 192.168.0.X.
     
  4. Buffrey007 thread starter macrumors newbie

    Buffrey007

    Joined:
    Jun 2, 2017
    #4
    I'll have a look at this when I get back home. How will I know if it's set as static? I've renewed the DHCP lease. I think my setting is 10.0.?? I'm not with my computer now but can check later. It's just hard to confirm if anything has worked when it works fine at home.
    --- Post Merged, Jun 2, 2017 ---
    In what way?
     

Share This Page