Strangely low FPS on WoW

marbz

macrumors newbie
Original poster
Dec 9, 2009
1
0
Okay well I have a sick ass mac that has always ran WoW simply beautifully, I have a 2.6 GHz intel core 2 duo processor, 4 gigs of ram a good video card. I am not low on memory in my hard drive and I remember about 2 weeks ago WoW was working fine ...

I took a break for a few weeks and now when I play I have a constant fps between 20 and 30 - it's ridiculous, my latency is always around 50 and I'm almost positive its not my internet connection...

Can anyone please help me and let me know what may be causing this and how I could fix it?
 

junior77

macrumors regular
Jun 29, 2007
122
0
Michigan
Okay well I have a sick ass mac that has always ran WoW simply beautifully, I have a 2.6 GHz intel core 2 duo processor, 4 gigs of ram a good video card. I am not low on memory in my hard drive and I remember about 2 weeks ago WoW was working fine ...

I took a break for a few weeks and now when I play I have a constant fps between 20 and 30 - it's ridiculous, my latency is always around 50 and I'm almost positive its not my internet connection...

Can anyone please help me and let me know what may be causing this and how I could fix it?
New patch came out yesterday, the servers have been bombarded with excessive amount of people. Blizzard also optimized the OPEN GL which probably has some bugs to be worked out....give it a week for things to calm down, I would expect to see some improvements with FPS.
 

QuantumLo0p

macrumors 6502a
Apr 28, 2006
988
28
U.S.A.
As junior77 mentioned the new patch came out so there could be a few things going on.

Is the updater running when you played? There are a couple of updater settings and one of them can affect game play performance. I can't remember the description of it but it is not the peer to peer setting; it is the other setting. It controls how much bandwidth the updater uses and if it is checked it will use all available bandwidth which obviously could cause the game to lag.

Perhaps a graphic setting is affecting it. You may want to try setting the WoW graphics options back to default then try running WoW again. Perhaps there is an option that worked okay before the patch but is causing some issues now.

Please post again and let us know what happens.
:)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.