Strangest internet problem you've probably ever heard of..

Discussion in 'MacBook Pro' started by Khurram, Jul 8, 2007.

  1. Khurram macrumors 6502

    Joined:
    Aug 28, 2006
    #1
    So I have a macbook which has been running perfectly since I got it about 7 months ago.

    During the last few days a new problem has come up.
    When i'm surfing around on the net all of a sudden the browsing will stop and it wont go to other sites or anything. The internet just stops working.
    To resolve this I have to click on the wireless logo on the top of the screen and then click on the name of my wireless connection again.



    Then after a minute or two it starts working again.

    After I click on the name of my wireless connection I can browse the net, however the site that I was trying to access when the connection originally got hung up still cannot be accessed! It goes to a page and acts as if the site doesn't exist. I get the 404 error page. However other sites will then work fine.
    If I try in a few minutes to go back to the page where the connection orginally got hung up it will work.
    This is getting really annoying because it's started to happen every 20 minutes or so, sometimes sooner.

    I know it's kinda hard to follow and I apologize for that, but just trying to get out all the details of the problem.

    I know it's not the router becasue my desktop and my wife's laptop do not encounter the same problem.

    I've checked her laptop during the time mine won't work, and I can browse the net perfectly fine. Ditto on my desktop.

    I do use openDNS, but I thought if it was a problem with that then why would the other computers on the network be working but not mine? the opendns config is on the router settings and not thru the individual computers.

    So has anyone ever experienced or heard of anything like this?
    It's starting to bug the crap of out of me!

    I've tried restarting my macbook, restarting the router, and rebooting the cable modem but no luck.

    Any advice would be welcomed
    Thanks
    Khurram
     
  2. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #2
    What could of router are you using? I've heard problems before about the connecton being dropped after a period and having to reconnect (applies to other computers beside Mac's).

    You tried connecting my cable instead to see if the problem still exists?
     
  3. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    Are there any computers on the network that do NOT receive an IP address via DHCP, and if so, what LAN IP address do they request? What lease duration does your router give? Is IPv6 enabled or disabled?
     
  4. WillMak macrumors 6502a

    Joined:
    Jul 29, 2005
    #4
    I had this problem on my macbook and the only way I was able to solve it was by not putting a password on the router.
     
  5. Khurram thread starter macrumors 6502

    Joined:
    Aug 28, 2006
    #5
    Thanks for the responses guys.

    I haven't changed the settings recently so I dont know why it would start all of a sudden.

    And the strange thing is, it doesn't actually say that the connection has been dropped, it still shows connected on the wireless icon.
     
  6. Khurram thread starter macrumors 6502

    Joined:
    Aug 28, 2006
    #6
    I would love to answer your questions, but I'm not sure!
    All of the computers connect directly to the router and i'm pretty sure they are all via DHCP.

    How do I know what lease duration the router gives? And also, I dont think I ever enabled IPv6 on my macbook. Should I, or should it be disabled?

    I'm using a linksys wrt54g w/ vonage.

    The only settings I recently changed were I enabled some port forwarding on my router's setup for use with BitTorrent
     
  7. Khurram thread starter macrumors 6502

    Joined:
    Aug 28, 2006
    #7
    Just checked in my router setup page,
    the client lease time is 0 minutes
     

Share This Page