Strangest/most miserable external HD situation

Discussion in 'Mac Accessories' started by jaaperific, Nov 30, 2010.

  1. jaaperific macrumors newbie

    Joined:
    Jan 18, 2010
    #1
    I have about 800gigs of files on my Western Digital 1.5tb external. This morning I accidentally pulled the wire a little bit and it fell about 2.5 ft but never hit the ground as i caught the wire. The harddrive is not making any noise and the light is on but it's not mounting on my macbook. Here's the strange part.. I went into Disk Utility immediately after to see what was up adn both my Harddrive and the disk I had created on it were there but I was unable to repair or do anything on them. I tried replugging it in and now the harddrive still doesn't mount but it shows up on Disk Utility as a TWO TB WD media. How is this possible? It's a 1.5 tb harddrive..

    The disc i had created on the hd is now gone as is everything from before. It's just showing a 2tb device with nothing on it. I don't know what happened but I'm desperate to get these files off. I went and borrowed a friend's 1 tb WD HD to copy everything on to it if I can access the files. They should all still be there and should not be corrupt because the disc did pop up once on disc utility but now it's gone. I've gone through a lot of forums and tried to find something similar to this but i haven't been able to and now i'm just lost and confused and really really really sad. Any body have any ideas on what to do here?

    extra: Downloaded a free trial of data rescue 3. I figured if it could show the files, i'd fork up the $100 for the full version so I could transfer it, however, data rescue 3 is also showing the 2tb harddrive and it says there are no files on it. This really concerns me (how do they all just disappear??) but I'm hoping for some positive news considering the HD is clearly not being read as what it is.

    Thanks for any help,
    Jaap
     
  2. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    I had a similar situation with a drive that had a corrupted partition that wouldn't mount (even though _other partitions_ on the same drive would mount). Disk Utility couldn't repair the corrupt partition -- no way to mount it on the desktop.

    DataRescue couldn't "touch" the un-mounted (corrupt) partition -- and couldn't "get at" the files on it.

    My "solution" to recover the files was to actually RE-INITIALIZE the entire drive into a single partition. Yes, re-initialize it.

    After that, the drive would mount, and DataRescue could then "scavenge" its contents and recover the majority of the files I needed.

    The reason this worked is because when you re-initialize a drive, you're not actually "wiping out" the actual data that resides on the various sectors of the drive. Instead, you're erasing the _directory_ (which represents the "table of contents" of the drive, and not the contents themselves), and then replacing it with a fresh one.

    The data itself remains untouched, so long as you don't write _new data_ onto the drive.

    Data Rescue (and a few other apps that work the same way, such as "Stellar Phoenix Data Recovery") doesn't care about the drive's directories -- instead, it looks directly to the data sectors of the drive, scavenges what it can find, and then attempts to re-assemble that data (which is saved to a second "recovery drive").

    You will lose all your folder hierarchies, because folders are a "creation" of the drives directory. But there is a high probability the data will recover ok.

    Again, the reason for re-initializing was to "make the drive mountable" (even if apparently "empty") so that DR could then "see it" and "attack" it.

    You WILL need a second drive onto which to recover the data.

    This worked for me, when it appeared that all was lost.

    If you can't find any other way to repair the damaged directory on the drive and make it mountable again, I suggest you try what I've outlined above before you give up completely.
     
  3. jaaperific thread starter macrumors newbie

    Joined:
    Jan 18, 2010
    #3
    @fishrrman

    Thanks for the suggestion. I do have a couple of questions for you:

    1) When this happened to you was your drive being read as something different than what it was? In my case, on the disc utility as well Data Rescue, my hd is showing up as 2 tb WD hd instead of the 1.5 TB that it is. Do you think this could be a symptom of the problem you had described as well?
    2) Assuming I do reinitialize, is there a possibility of a data loss to prevent me from undertaking other options? Basically, is this a final resort? I'm not worried about losing the directories if I can retain the files.
    3) Finally, and I guess most importantly, how exactly do I go about "reinitializing" the drive anyway? Sorry for the n00b question, but I don't do a lot of HD management (as you can probably tell or I would've backed this drive up lonngggg ago).

    Thanks for the unique suggestion and all of your help. Hopefully this will let me recover my files.
    Jaap
     
  4. jaaperific thread starter macrumors newbie

    Joined:
    Jan 18, 2010
    #4
    Actually, after rereading your post, I think I understand what you're saying. You took a multiple partition drive and made it into one again? If that's the case, I have a couple more questions for you.
    1) What do you do if there is only one partition? Is there a way to "reinitialize" in that situation?
    2) Would you recommend creating a partition and then reverting back to one partition?

    Thanks again!
    Jaap
     
  5. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #5
    "1) What do you do if there is only one partition? Is there a way to "reinitialize" in that situation?
    2) Would you recommend creating a partition and then reverting back to one partition?"

    If the drive currently has only one partition, you should not need to do anything except re-intialize it. That is, NO partitioning afterwards.

    IMPORTANT! IMPORTANT! IMPORTANT!
    WARNING! WARNING! WARNING!

    Do not, DO NOT "zero out" the drive. MAKE SURE you DO NOT do this! If you do, it WILL "wipe the sectors clean" and there will be nothing left for DR to recover!

    All you want to do is a simple "re-initialization".

    Just get it to mount on the desktop as an "empty" drive, and let Data Rescue "go to work on it".

    Again, I suggest this as a LAST RESORT when you have absolutely tried EVERYTHING else before.
     
  6. jaaperific thread starter macrumors newbie

    Joined:
    Jan 18, 2010
    #6
    @fishrrman

    thanks for the suggestion. def worth a shot and i had not heard anyone else recommend it. however, as soon as i tried reinitializing i got an input/output error. guess that was my last shot :\
     
  7. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #7
    Did you try a new data cable. Also it may be worth a shot to try another enclosure if you have one laying around.
     
  8. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #8
    "however, as soon as i tried reinitializing i got an input/output error. guess that was my last shot :\"

    It could be either a bad enclosure, or perhaps the controller card on the drive mechanism itself is bad.

    You _might_ consider trying this:

    Get something like this:
    http://www.amazon.com/Syba-Connecla...?ie=UTF8&s=electronics&qid=1253062702&sr=1-22

    Then, take the drive out of the enclosure it's in now, and put it into the dock.

    Do things work any better?

    If the enclosure was bad (and NOT the drive inside), you may suddenly find things "back to normal" -- no file recovery necessary.

    Note:
    Above info assumes the core drive in the enclosure is a "SATA" type drive.

    If it is an older "IDE/ATA" type drive interface, it won't fit into a SATA/USB dock. Instead, you need something like this:
    http://www.newegg.com/Product/Product.aspx?Item=N82E16812119152&Tpk=Rosewill rcw 608

    Not as nifty as a "dock", but this gadget will connect BOTH SATA and IDE/ATA type drives via a USB cable.

    If even a "docking solution" fails to work, then it's probably the controller card on the drive, or some other "internal problem" with the drive mechanism itself.
     

Share This Page