Stream mp4 in Safari, instead of it downloading

Discussion in 'MacBook Pro' started by hogsrul, Jan 4, 2012.

  1. hogsrul macrumors member

    Joined:
    Feb 27, 2011
    #1
    Ok, I have tried searching but I can't find the answer. Before switching to Lion, I could click on .mp4 files and they would play directly in safari (I assume by using quicktime?), but now, when i click on .mp4 files it goes straight to downloading, which i don't want. What can I do to fix this?

    Thanks,
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    I guess you use Safari's Activity Monitor? Or are you using direct links to .mp4 files? If it is the former, maybe try CMD or OPTION clicking the file instead of the simple click?
     
  3. hogsrul thread starter macrumors member

    Joined:
    Feb 27, 2011
    #3
    I tried that and it still just starts downloading in igetter.
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    What if you disable iGetter or uninstall it?

    As I don't use Lion, I can't test though.
     
  5. hogsrul, Jan 4, 2012
    Last edited: Jan 4, 2012

    hogsrul thread starter macrumors member

    Joined:
    Feb 27, 2011
    #5

    I will try turning the extensions off
     
  6. hogsrul thread starter macrumors member

    Joined:
    Feb 27, 2011
    #6
    this still doesn't do the trick :( I'm not sure what the deal is.
    In the past, I was able to just click the direct link and it would start playing the video, now it wants to start downloading, even if i disable igetter, it just downloads in safari.

    this is frustrating.
     

Share This Page