Streaming from iMac to Xbox360 - problem!

Discussion in 'iMac' started by deadasdillinger, Jan 11, 2013.

  1. deadasdillinger macrumors newbie

    Joined:
    Jan 11, 2013
    #1
    Hi all,

    Just joined forum in a bid to solve my mac problem! I've Googled hell out of this problem and have seen a few links discussing it, some here, but none have solved it.

    Trying to get my iMac and Xbox360 speaking to each other. I've just set up a home cinema with my Xbox, a projector and a 70" screen, and I want to take advantage of the projector's HD capabilities by streaming .mkv and .mp4 files - plus with the new speakers I've got it would be nice to be able to stream my music collection.

    I've tried Connect360, Rivet and PS3 Media Server, the three apps that are apparently the best for streaming from iMac to Xbox360, and none have worked. I go into Network on my 360 and search for PC Connection, nothing comes up - I open the apps on the iMac and they don't find my Xbox360.

    Running Mac OS X, 10.7.5, which connects wirelessly to my Huawei Broadband Wireless ADSL2+ router. My 360 model doesn't have a wireless adapter built-in, so I connect to it via a dongle. I've read suggestions that I should try a wired connection and see if that works but it's not really an option with my setup.

    I have tried things like checking firewall settings and so on but open to any suggestions. Would really love to get this up and running. Thanks.
     
  2. torana355 macrumors 68020

    Joined:
    Dec 8, 2009
    Location:
    Sydney, Australia
  3. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #3
    Might look inside the router, there are firewalls there and you might need port forwarding.
     
  4. deadasdillinger thread starter macrumors newbie

    Joined:
    Jan 11, 2013
    #4
    Looking at the Traces log on PMS, it says:

    "Unable to bind to 1900, which means that PMS will not automatically appear on your renderer! This usually means that another program occupies the port. Please stop the other program and free up the port. PMS will keep trying to bind to it...[Address already in use]"

    How would I find out what program is using the port? Or can I change PMS settings to use another port?
     
  5. justperry, Jan 11, 2013
    Last edited: Jan 11, 2013

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #5
    If you paste this into terminal and hit enter it shows which port is used by what program.

    lsof -l

    Edit 1: Found this on google but does not seem to show ports.

    Edit 2: Found the below one but still no ports.

    lsof -i

    Edit 3: Try one off these, I can't, my port is not open.
    sudo lsof -i -P |grep LISTEN This one seem to work well.
    sudo lsof -i -P |grep 1900
     
  6. Chuckstones macrumors regular

    Joined:
    Oct 28, 2012
    #6
    I am having a similar problem!

    downloaded the ps3 media server .As i just cannot seem to get my subwoofer to kick in with apple tv. Even though it is connected exactly the same way as my xbox 360 to my av amp whilst streaming. No 5.1 (any ideas?)!

    It is showing the location in music app on my xbox but not music (artists, albums etc.)
    Am i missing something here!!?!
    can the xbox play AAC files as well as mp3 via ps3 media server (most of my music is still in mp3 format since transferring from pc. only recent purchases from iTunes are AAC!!

    IT is really bugging me this. as i just bought some creative T20 desktop speakers and they are tremendous. loads of bass whereas my surround set up sounds thin in comparison. (was fine through xbox streaming from WMP):(
    And i dont think it is a router problem. as it allowed me to stream before!
     
  7. AndiS. macrumors regular

    Joined:
    Dec 16, 2012
    #7
    Same here, wanted to stream through Playstation, but it turned out that my TV has this functionality as well. Media Server detected the TV right after installation.
     
  8. deadasdillinger thread starter macrumors newbie

    Joined:
    Jan 11, 2013
    #8
    Anyone able to shed some light on what I could do to resolve this ?
     
  9. AndiS. macrumors regular

    Joined:
    Dec 16, 2012
    #9
    This is just a guess, but I think it has to do with your wireless dongle. Even though trying a wired connection might not be a permanent solution for you, could you maybe give it a try just to see whether that resolves the issue?

    Which wireless adapter are you exactly using for your Xbox?
     
  10. deadasdillinger thread starter macrumors newbie

    Joined:
    Jan 11, 2013
    #10
    Could possibly get hold of some extra long ethernet cables and give it a go.

    The dongle is this - http://www.amazon.co.uk/Xbox-360-Wireless-Network-Adaptor/dp/B000AYTQ7O

    I know the iMac and Xbox have to be on the same network so I'm guessing the dongle adds a layer of confusion to matters, if your theory is right?

    Will give it a try tomorrow and report back.
     
  11. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #11
    I don't think the Dongle is the problem here.

    As in my above test do this first:

    1. Open Terminal, it is located in the Applicatios/Utilities folder

    2. Paste this command: sudo lsof -i -P |grep LISTEN

    3. Enter password

    4. Hit enter and text should turn up in a bit

    5. you can see which Application uses the 1900 port

    I do not have PMS, I don't have the need to but I am quite positive you can change the ports, but you then might also need to change the port on the XBox.

    A problem could also be the router and you might need to do port forwarding or enable UPnP.

    To get into the router:

    Open System Preferences, next click on the active network, wireless one in this case, click on advanced and then the TCP/IP tab, under Router you'll find the IP of the router, most of the time this is 192.168.1.1 but can be different.
    Copy this number to the URL bar in Safari( Or any other browser) and hit enter.
    It most likely asks for login, it's almost always admin/admin for Login/password.
     
  12. Dopeyman macrumors 6502a

    Joined:
    Sep 5, 2005
    Location:
    Los Angeles!
    #12
    I use Playback for my streaming to my PS3... It's also compatible with the 360..

    Give that one a shot..
     

Share This Page