strikethrough text on snow leopard

Discussion in 'macOS' started by pendolino, Nov 12, 2009.

  1. pendolino macrumors member


    Feb 13, 2007
    now that snow leopard has been released, i wanted to revisit the question of whether there was a way to assign a shortcut or hotkey to strikethrough (strikeout) text universally across all text applications and editors.

    does anyone know how to do this?

    note that in no way do i want to have to mouse over to menus to do this but want a key combo that will do it at once to selected text.
  2. EspressoLove macrumors 6502


    Jun 29, 2007
    Bay Area

    Yes, that would be great to have such keyboard shortcut.
    I have it only in a Scrivener (⌘⇧_), though I vaguely remember having it somewhere else.

    If anybody know a shortcuts for strike-through in specific apps, please chime in.
  3. pendolino thread starter macrumors member


    Feb 13, 2007
    if there was a menu command for it then we could set a keyboard shortcut in the keyboard preferences but i have not found one.
  4. Ashka macrumors 6502a


    Aug 9, 2008
    New Zealand
    Any app the uses Apples font book has the strikeout option but not a quick key command.
    Open TextEdit > Format > Fonts > Show fonts > Strikeout is the second icon from the left..
  5. samandbeans macrumors newbie

    Jul 11, 2011
    strikethrough text on snow leopard

    Command + Shift + X is the shortcut for strikethrough
    "View, Toolbars, Customize toolbars, Keyboard, (then select either Format style or strikethrough- under "commands")
  6. gje21c macrumors newbie

    Jun 5, 2010

    Command + Shift + X is not working for me.
    (In TextEdit, MacBook black 15", Snow Leopard 10.6.8)

    Also can't follow your instruction "View, Toolbars, Customize toolbars, Keyboard, (then select either Format style or strikethrough- under "commands"

    There's no View in TextEdit or Font Panel. Tried Settings, Keyboard but no ability there to customise appearanace features like Bold, Italic, Strikethrough.

    Sorry to be dense ! Could you step through it in more detail ?
    Many thanks,
    Greg E
  7. Aaroneous macrumors newbie

    Oct 12, 2011
    Would a checkmark do?

    Eh I've been looking for a strikethrough shortcut too and have had no luck. I did stumble upon how to make a quick checkmark; though, and I've been using that as a replacement for the strikethrough.

    Opt - v

    (Not usually an integral)
  8. StoryMcQueen macrumors newbie

    Dec 11, 2011
    How to assign strikethrough key for Text edit.

    I have successfully assigned a key for strikethrough for text edit, however it's not working for stickies and I don't have iwork or mac word.


    Apple Menu,
    open System Preferences
    Click on Keyboard
    Scroll down the left side to Applications Shortcuts, at the bottom.
    Then click the + (it's there at the bottom of the devider bar (+&-) to open a a new pop up menu.
    Where it says Applications, click the arrows to get to the The Text Edit (It won't work set as All Applications)
    Enter the menu title EXACTLY AS WRITTEN in the text edit drop down menu which is "Struck through" (case and spacing and the past tense matters) I copied and pasted it.
    Choose a key stroke. I chose "command /"
    Click Add
    Close out of system preferences.
    Quit and Restart text edit.

    This will work.

    I cannot, however use the same command to un strike-through. So I copied and pasted "Default" into the same instructions giving it the key command of "Command Shift /". It's a little iffy, but if you found something better, let me know.

    Good luck, All.

    -Story McQueen
  9. EspressoLove macrumors 6502


    Jun 29, 2007
    Bay Area
    Wow, McQueen you are a genius :)

    It's of little practical value for me (only works with "RichText" and only when Ruler is shown) :rolleyes:
    But I'm still puzzled at how did you find it :eek:
  10. snipper macrumors regular


    Feb 9, 2004
    10.7.4 Dutch localisation

    Sorry for the bump but I've been looking for a strike through shortcut for long and hoped this would work for me. I just installed 10.7 (updated to 10.7.4 immediately) and I can't get the shortcut to work (in TextEdit). I must add that I'm using the Dutch localization. I tried the English 'Struck Through' and the Dutch 'Doorgehaald' menu items.

    McQueen, do you have more idea's about this?

Share This Page