Struggling to make a bootable 10.6 external HDD

Discussion in 'macOS' started by Candlelight, Feb 12, 2014.

  1. Candlelight, Feb 12, 2014
    Last edited: Feb 12, 2014

    Candlelight macrumors 6502a

    Candlelight

    Joined:
    Oct 12, 2011
    Location:
    New Zealand
    #1
    I format the drive, run the installer, it reboots, installs the remaining software, then when it reboots into the first run screen... it doesn't, instead booting into the computer I've used to make the drive. Now when I try to boot into the HDD there is no user directory and obviously can't run.

    I've tried this on two machines with three different hard drives, and two different installer discs. Is there an known issue with making 10.6 bootable HDDs? Or am I just really unlucky? :)

    Also, is it possible to make an external drive bootable with both Snow Leopard and Mavericks? Or would the 'firmware' (or whatever) from Mavericks cause Snow Leopard to stop working?
     
  2. MacUser2525 macrumors 68000

    MacUser2525

    Joined:
    Mar 17, 2007
    Location:
    Canada
    #2
    Hold down the option key when booting the new external install so you get the screen to pick which drive you want to boot. For the second question not certain but I see nothing to prevent you from a dual boot on external providing the machine you are on supports Mavericks.
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    Are you choosing the external hard drive as the destination for the 10.6 install?
    What format are you using for the external hard drive?
    I'm assuming that you have the external drive formatted as GUID, as the installer won't allow you to install unless the hard drive is formatted GUID.

    Yes, you can install both 10.6 and 10.9 on the same hard drive. Each system simply needs separate partitions. And, you need a Mac that will boot to either OS X version, to be able to install.
    (I have one hard drive, with separate bootable partitions for every OS X from 10.4 to 10.9. The newer systems are more challenging, and have to be cloned on from another disk, but my hard drive will boot every Mac from G3s to very recent Macs. Just have to know which ones can't boot because they are too old, or too new!)

    Your 10.6 install problem sounds like your are NOT choosing the external as the destination.
    Here's another method: Insert your 10.6 installer DVD. DON'T run the installer, but DO restart your Mac, holding the letter C. That will force your Mac to boot to the installer. Watch for the screen where you can change the destination for the install, and make sure that you have the external hard drive selected.
     
  4. Candlelight thread starter macrumors 6502a

    Candlelight

    Joined:
    Oct 12, 2011
    Location:
    New Zealand
    #4
    Mac OS X Journaled, GUID partition table.

    That's EXACTLY what I'm trying to do! I want to have a drive that does exactly that. How did you clone them? Carbon Copy Cloner?

    Did you start with 10.4 and work up? Or the other way round?

    I'm a bit confused by that though; I would've thought it would automatically choose to boot into that destination considering it's just spent the last 40 minutes writing to it! (I can pick the destination and get 99% of the way through, I just can't first run the drive)
     
  5. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    Don't forget that you can also install on your internal drive, assuming that it was already installed and using 10.6. You might not even notice that you installed on your internal drive.
    That's why you need to make sure about which drive is selected for the destination for the installer. The installer can't read your mind about which partition, or drive, that you install to.
    However, if your are certain that you chose the external, and it seems to install OK, then yes, it should attempt to boot to that external drive. Another way to check is to see if the folders for your system on the external have dates and times from approximately when you just installed. If that looks OK, then do the Option-boot choice to boot from your external drive.
    Your question about how did I install all of those systems? all were separately installed. I also have all installers, also on separate partitions on that hard drive. It makes OS X installs much faster (and more reliably) than from DVDs.

    I don't use third-party software, but just use the Disk Utility to clone the bootable partitions, using the restore tab. You can use something else if you wish, but that's just my choice.

    Where did you get your 10.6 installer DVD? maybe you have a bad DVD?
    Here's something that I use: Boot to your Mac. insert your installer DVD, and use Disk Utility to Restore your installer DVD to an 8GB USB flash drive. Use that flash drive to install 10.6
    If you need to try different methods for the install, and several attempts, the flash drive will at least save you some time.
    Lastly: when the OS X install is complete on your external HD, but STILL doesn't boot after the restart - Does it appear in the Option-Boot screen as a bootable partition? And, what happens if you choose that external, then continue to boot from that screen.
     
  6. Candlelight thread starter macrumors 6502a

    Candlelight

    Joined:
    Oct 12, 2011
    Location:
    New Zealand
    #6
    Thanks for this.

    First, I'm definitely selecting the external drive. It's installing to it, just won't perform the first run, even if I bail and manually select it later.

    "My" machine is Mountain Lion, but the machine I'm using was and always will be Snow Leopard (I have five computers on my desk, long story). The DVDs I'm using are retail versions and are either 10.6.0 or 10.6.3. I tried just before to do a Leopard 10.5 install but had the grey circle with the line through it when it got to the first run screen (I'm guessing Apple won't let you first run an OS that's less than your current machine). I do have access to a Mac Mini which runs Leopard so I should probably use that machine?

    Did you do them 10.4 up or 10.9 down?

    I'm using a 1TB Adata drive as my Multiple OS's HDD.
     
  7. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #7
    The "prohibited" symbol usually comes up because you are trying to boot to a system that particular Mac does not support.

    No, the OS X installers are simple. Just clone, or restore the installer to a hard drive partition. I try to create a blank partition first that is about a couple of hundred MiB larger than the installer itself, so every installer partition is a different size. You don't need to boot to anything special just to clone the installer disk.
    Making a booting system is completely different. You have to boot to a Mac that supports that version to install. The hard drive partition has to be formatted (full erase is good, too) to allow booting on that Mac. The installer should automatically restart to provide a new user setup on the first boot after the install. . I guess that's what you mean by "first run"

    My guess is that your Adata HD firmware may not support booting on your Mac.

    WHICH Mac mini do you have with Leopard? If it is a G4 mini, then you can't boot or install 10.6. If it an intel Mac (core duo or core 2 duo), then yes, you can try that. The booting challenge could be hardware, so be sure to try a different USB cable with the same Adata HD.
    Finally, is the Adata drive self-powered (with its own power cord, or external power box) or bus-powered (no other connection except the USB cable)
     
  8. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #8
    [[ I format the drive, run the installer, it reboots, installs the remaining software, then when it reboots into the first run screen... it doesn't, instead booting into the computer I've used to make the drive. Now when I try to boot into the HDD there is no user directory and obviously can't run. ]]

    It can be difficult to diagnose situations like this, when one can't be near the machine that is having the problem.

    Let's clarify...

    You are saying that you ran the 10.6 installer and installed the OS onto an external drive, correct?

    And you are saying that the installer "completed the job", but when you tried to boot into the new OS, it wouldn't boot from the external drive, is this also correct?

    Something to be aware of:
    I've run into external drives (both firewire and USB) that wouldn't boot a Mac, regardless of what one did. Seems to be a hardware or firmware problem with the drives, not a fault in the Mac OS.

    Something to try (as mentioned in reply 2):
    Shut everything down. Power EVERYTHING all the way off.
    Now, apply power to the external drive.
    Next, press the start button on the Mac.
    IMMMEDIATELY hold down the option key and KEEP HOLDING IT DOWN, until the startup manager appears (may take a number of seconds).

    The startup manager will show you all the volumes it finds (internal and external drives, etc.) that have a bootable OS.
    You should see the internal drive, of course.
    If the external drive you've installed to has a valid and bootable copy of the OS, it should show up, too. If it doesn't show up, something is wrong.
    The problem could be that the software installation failed. Or, it could be a hardware problem with the drive itself (refer to "something to be aware of", above).
    If you DO see the OS on the external drive, move the pointer over it (mouse or use arrow keys) and then hit "return".
    What happens next?
     
  9. Candlelight thread starter macrumors 6502a

    Candlelight

    Joined:
    Oct 12, 2011
    Location:
    New Zealand
    #9
    - I'm primarily using a MacBook Pro4,1 which came with leopard, so it should boot into a Leopard partition!

    - I have a similar Adata drive (a 500GB compared to this 1TB drive) which has a bootable Mavericks and Lion partition on it. I was trying to add Snow Leopard to it but it didn't work, so I tried another drive.

    - I hadn't considered just adding the installers to the partition. I figured it would be more useful to boot into a user environment on each partition for each OS.

    - I haven't used the Mac Mini yet but it's an Intel running Leopard.

    - I have installation discs for 10.4.8 (Intel), 10.5.8, 10.6.3 (or 10.6.0, is there a way to check?), 10.7.1 and digital installers for 10.8.5 and 10.9.1.

    ----------

    As I said above I have a successful Adata 500GB drive with Lion and Mavericks and was trying to add a third partition for Snow Leopard.

    But neither the 500GB or 1TB Adata will accept Snow Leopard. It simply won't let me first boot into the drive to create a user directory. When I hold down option on start up the external drive is visible but doesn't launch (I get the prohibited circle). This has happened now for both Leopard and Snow Leopard (on a MacBookPro4,1 which has never been higher than Snow Leopard).
     
  10. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #10
    Keep in mind that the 10.4.8 for Intel is for ONE specific Mac model. (Apple never released a universal version of the Tiger installer that would install on all Intel Macs)
    If you have the Startup Disk pref pane open, and an installer DVD in your drive, it will show what version the boot software is - which is the specific version that would be installed.
    And, of course, 10.7 and later is only available as downloads.

    Finally, if you can't boot to a new install of OS X, there's only a couple of reasons.
    The system install is corrupted.
    The Mac is not compatible with the version being installed.
    The hard drive or other storage device is not bootable (incompatible firmware)
    The external hard drive enclosure does not do a good job of getting power to the hard drive, or has flaky electronics (the drive hardware is not reliable)
    For example, I have one hard drive (multiple partitions) that I have learned to cycle the power on the enclosure when restarting. The drive may not "catch" the first time if I don't restart the power on the drive. I wonder if that same tip may help you, too?
     
  11. macuserclint macrumors newbie

    Joined:
    May 23, 2014
    #11

    I have an old Mac Pro, 2,1 late 2007 model running 2x quadcore 3.0 ghz Xeon processors. I'm using snowleopard and it has been my workstation for a long time.

    Recently I had an issue with Python and couldn't get Django installed correctly for a course I'm taking, My advisor told me to upgrade to mavericks. So, I found that my machine wasn't supported because of 32bit efi. Not sure what that means. It runs 64 bit programs like Maya and Nuke like a champ, so apparently 64 bit and 64bit efi are different things. Anyways, I did some research and found the sfott 32 to 64 tool and used it to install mavericks on my machine. I found it at oemden.com

    Because snowleopard was working fine, I decided to install mavericks In a brand new separate drive.

    Mavericks works fine, other than some video card issues, I get some random, rgb pixels on my monitor now and my second display isn't detected at all. But I can do the python Django training so I'll live. I'm using a quadrofx 4500.

    But now, when I boot into snowleopard on my other hd, it freezes almost every time. Most of the time it gets stuck on the white screen after the apple logo. Sometimes I'm lucky enough to get it logged in but it freezes randomly. I always have to hard boot to get it back.
    I tried using disk utility while in mavericks and after running repair permissions and repair disk it stated that the drive was in good shape. Because I can run things in mavericks I don't think it's a memory issue.

    I thought because I installed mavericks on separate drive it wouldn't affect my snowleopard drive.

    Any suggestions, thoughts?
     

Share This Page