stubborn Home Sharing - iOS problem...

whyrichard

macrumors 68000
Original poster
Aug 15, 2002
1,669
2
Hey,

My Apple TV2 is no longer able to home share with my Mac Pro '09. I can't actually tap into my Mac Pro's itunes library from ANY ios device...

this started in the past few months and the the main thing that has changed is Mavericks and ios 7.

How do i go about diagnosing this and fixing it!?!? There are many others having problems: https://discussions.apple.com/message/24245402?ac_cid=tw123456#24245402

but i have no luck getting any ios device, specifically my Apple tv2, to work with home sharing at all with my Mac Pro!

My network is a new airport express. Everything is on the same network. Everything is wireless. Everything is up to date with software.

I CAN access my mac pro through home sharing from my macbook air with no problem...

and I CAN access my macbook air's itunes library from other ios devices...

... any suggestions?

Thanks,

Richard
 

waw74

macrumors 68040
May 27, 2008
3,407
291
Tried turning home sharing off and on on the Mac Pro?

Quit iTunes, and relaunch while holding down the option key. Create a new library. Try setting that up, and importing a couple songs to see it if works, maybe your library got corrupted.
(Your old library will remain unchanged, you may need to do the option trick again to reflect it when you restart)
 

whyrichard

macrumors 68000
Original poster
Aug 15, 2002
1,669
2
Tried turning home sharing off and on on the Mac Pro?

Quit iTunes, and relaunch while holding down the option key. Create a new library. Try setting that up, and importing a couple songs to see it if works, maybe your library got corrupted.
(Your old library will remain unchanged, you may need to do the option trick again to reflect it when you restart)
thanks, I tried that but it didn't work.
And previously i did try to log out of my itunes account, turn off home sharing, restart, etc...

anything else i can try?
i have a feeling it has something to do with my mac pro's wifi... or sharing setup, which i had done my best to reset but it still does not work...

r.
 

priitv8

macrumors 68040
Jan 13, 2011
3,631
476
Estonia
i have a feeling it has something to do with my mac pro's wifi... or sharing setup, which i had done my best to reset but it still does not work...
Home Sharing actually has nothing to do with sharing on your computer (unless you use it to create a Wi-Fi hotspot or ad-hoc network).
There are 2 vital things for HS to work:
- Bonjour service broadcast
- HS authentication against iTunes Store.
If you can't even see your iTunes library from other iOS devices, it's the Bonjour at fault. Or networking in general.
PS Have you checked this list?
http://support.apple.com/kb/TS2972
PPS You can visualize Bonjour advertisements with a tool like Bonjour Browser. There are both Mac and iOS versions available:
http://www.tildesoft.com
https://itunes.apple.com/en/app/discovery-bonjour-browser/id305441017?mt=8
 

whyrichard

macrumors 68000
Original poster
Aug 15, 2002
1,669
2
Home Sharing actually has nothing to do with sharing on your computer (unless you use it to create a Wi-Fi hotspot or ad-hoc network).
There are 2 vital things for HS to work:
- Bonjour service broadcast
- HS authentication against iTunes Store.
If you can't even see your iTunes library from other iOS devices, it's the Bonjour at fault. Or networking in general.
PS Have you checked this list?
http://support.apple.com/kb/TS2972
PPS You can visualize Bonjour advertisements with a tool like Bonjour Browser. There are both Mac and iOS versions available:
http://www.tildesoft.com
https://itunes.apple.com/en/app/discovery-bonjour-browser/id305441017?mt=8
hey,

I tried everything in that list from apple. no change.

i downloaded bonjour browser, and it comes up with this list... how does it look?
 

Attachments

whyrichard

macrumors 68000
Original poster
Aug 15, 2002
1,669
2
Looks like the very _home-sharing._tcp. is missing.
Check your iTunes account status and HS settings.
i logged out of my itunes account and back in, and turned off home sharing, quit, etc, but this is what i get!

how do i get this back?!?!

YOU ARE FANTASTIC! I TRUELY APPRECIEATE YOUR HELP! This has been plaguing me for soooo long! it would be so great to finally fix it!

r.
 

priitv8

macrumors 68040
Jan 13, 2011
3,631
476
Estonia
What IP addresses do you see, when you expand the following nodes?
_atc._tcp.
_airplay._tcp.
_appletv-v2._tcp.

PS Does your iTunes library have a name assigned?
PPS If you are confident on command line, what do you see when you issue the following commands:
To see what instances of _home-sharing are registered / deregistered and when, run this command and observe on command line what happens when you run/quit iTunes and sign on/off to Home Sharing (in File menu):
Code:
$dns-sd -B _home-sharing._tcp local.
Browsing for _home-sharing._tcp.local.
DATE: ---Sun 29 Dec 2013---
19:54:45.607  ...STARTING...
Timestamp     A/R    Flags  if Domain               Service Type         Instance Name
19:59:10.243  Add        2   4 local.               _home-sharing._tcp.  [B]Priit’s Library[/B]
20:03:29.922  Rmv        0   4 local.               _home-sharing._tcp.  Priit’s Library
Now take the service instance name from the rightmost column and issue this command (if name has spaces, surround with quotes as in my example):
Code:
$ dns-sd -L "Priit’s Library" _home-sharing._tcp local.
Lookup Priit’s Library._home-sharing._tcp.local.
DATE: ---Sun 29 Dec 2013---
20:05:24.809  ...STARTING...
20:05:24.810  Priit’s\032Library._home-sharing._tcp.local. can be reached at [B]Priits-MacBook-Pro.local.[/B]:3689 (interface 4)
 txtvers=1 dmv=131082 hQ=138 MID=0x97A9025304AE61A0 Version=196620 iTSh\ Version=196618 PrVs=65538 Machine\ Name=Priit’s\ Library OSsi=0x1F7 hG=00000000-1149-92d4-5602-3e5ed10949cc Database\ ID=F5D2283586F3C910 Machine\ ID=F0BA8E1A1306 hC=aeff9330-7cb5-45c1-b9c4-7d19a7d1c3ab
Now take your computer's name from previous output and issue:
Code:
$ dns-sd -G v4v6 Priits-MacBook-Pro.local.
DATE: ---Sun 29 Dec 2013---
20:11:55.889  ...STARTING...
Timestamp     A/R Flags if Hostname                               Address                                      TTL
20:11:55.890  Add     3  4 Priits-MacBook-Pro.local.              FE80:0000:0000:0000:2ACF:E9FF:FE13:EDF7%en0  120
20:11:55.890  Add     2  4 Priits-MacBook-Pro.local.              192.168.0.7                                  120
What results do you get?
 

whyrichard

macrumors 68000
Original poster
Aug 15, 2002
1,669
2
What IP addresses do you see, when you expand the following nodes?
_atc._tcp.
_airplay._tcp.
_appletv-v2._tcp.

PS Does your iTunes library have a name assigned?
PPS If you are confident on command line, what do you see when you issue the following commands:
To see what instances of _home-sharing are registered / deregistered and when, run this command and observe on command line what happens when you run/quit iTunes and sign on/off to Home Sharing (in File menu):
Code:
$dns-sd -B _home-sharing._tcp local.
Browsing for _home-sharing._tcp.local.
DATE: ---Sun 29 Dec 2013---
19:54:45.607  ...STARTING...
Timestamp     A/R    Flags  if Domain               Service Type         Instance Name
19:59:10.243  Add        2   4 local.               _home-sharing._tcp.  [B]Priit’s Library[/B]
20:03:29.922  Rmv        0   4 local.               _home-sharing._tcp.  Priit’s Library
Now take the service instance name from the rightmost column and issue this command (if name has spaces, surround with quotes as in my example):
Code:
$ dns-sd -L "Priit’s Library" _home-sharing._tcp local.
Lookup Priit’s Library._home-sharing._tcp.local.
DATE: ---Sun 29 Dec 2013---
20:05:24.809  ...STARTING...
20:05:24.810  Priit’s\032Library._home-sharing._tcp.local. can be reached at [B]Priits-MacBook-Pro.local.[/B]:3689 (interface 4)
 txtvers=1 dmv=131082 hQ=138 MID=0x97A9025304AE61A0 Version=196620 iTSh\ Version=196618 PrVs=65538 Machine\ Name=Priit’s\ Library OSsi=0x1F7 hG=00000000-1149-92d4-5602-3e5ed10949cc Database\ ID=F5D2283586F3C910 Machine\ ID=F0BA8E1A1306 hC=aeff9330-7cb5-45c1-b9c4-7d19a7d1c3ab
Now take your computer's name from previous output and issue:
Code:
$ dns-sd -G v4v6 Priits-MacBook-Pro.local.
DATE: ---Sun 29 Dec 2013---
20:11:55.889  ...STARTING...
Timestamp     A/R Flags if Hostname                               Address                                      TTL
20:11:55.890  Add     3  4 Priits-MacBook-Pro.local.              FE80:0000:0000:0000:2ACF:E9FF:FE13:EDF7%en0  120
20:11:55.890  Add     2  4 Priits-MacBook-Pro.local.              192.168.0.7                                  120
What results do you get?
These are the ip addresses from Bonjour Browser...

I got to step 2 with the terminal...

The first command i put in was: dns-sd -B _home-sharing._tcp local
and i get the attached results:

but then the next command yields no results: dns-sd -L “Ditchey MacPro” _home-sharing._tcp local

what am i doing wrong?

thanks a million times again..

r.
 

Attachments

priitv8

macrumors 68040
Jan 13, 2011
3,631
476
Estonia
I immediately see 2 problems (see pics):
1) Your Mac Pro has only a IPv6 address and this is a loopback address (127.0.0.1 in old IPv4 days)
2) Your _home-sharing is registered on 2 different interfaces (#1 and #6). Do you have 2 network adapters simultaneously active?
PS you can see, which interfaces the #1 and #6 are if you run the command in Terminal and count the interfaces (name starts in 1st column and ends with a colon):
Code:
$ ifconfig -a
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
	options=3<RXCSUM,TXCSUM>
	inet6 ::1 prefixlen 128 
	inet 127.0.0.1 netmask 0xff000000 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
	nd6 options=1<PERFORMNUD>
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
[B]en0[/B]: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	ether 28:cf:e9:13:ed:f7 
	[B]inet6 fe80::2acf:e9ff:fe13:edf7%en0 prefixlen 64 scopeid 0x4 
	inet 192.168.0.7 netmask 0xffffff00 broadcast 192.168.0.255[/B]
	nd6 options=1<PERFORMNUD>
	media: autoselect
	status: active
Now copy the first and 6th interface descriptions to here.
For example, my Interface 4 that dns-sd reported, happens to be my active AirPort wireless adapter, the en0. I've highlighted the normal-looking IPv4 and IPv6 addresses.

So basically, your Mac Pro is not on your local network with a valid, unique IP address.
You should review your network adapter settings, perhaps using the assistant.
For comparison, I've included a screenshot from my Shared iTunes Library service (_atc._tcp.).
The most blatant case would be simply a failure of your network adapter card or wiring!
I'd have a look at the Info tab in Network Utility first and see through the statii of all network interfaces:
 

Attachments

Last edited:

whyrichard

macrumors 68000
Original poster
Aug 15, 2002
1,669
2
priitv8... YOU ROCK.

i was not able to figure out your instructions, but based on your keen observations i network preferences, and deleted everything but my wifi in the leftmost column... as well as renewing my dhcp license. set my ipv6 to automatic (i had turned it off using the terminal trying to fix this in the past)...


..AND MY APPLE TV CAN NOW ACCESS MY MAC PRO'S VIDEOS!!!!

thank you.

my ipad, however, still cannot. but it can at least SEE the home share. when selecting the home share it just spins and spins.

attached is my current bonjour browser reading... do i still have the same problem? or is my ipad just a bit weak in the home sharing? (it is a first get ipad mini)


thank you so much for your help so far, it is amazing to be able to use my apple tv again.

r.
 

Attachments

priitv8

macrumors 68040
Jan 13, 2011
3,631
476
Estonia
Glad to hear you can enjoy your media library again!
Try to get a Bonjour Browser view directly from the iPad, using the iOS version of the program!
PS how large is your library? I also see it spin prolonged times occasionally as it tries to buffer the library metadata (incl artwork) on the iOS device.
 

whyrichard

macrumors 68000
Original poster
Aug 15, 2002
1,669
2
Below is the text from the ios version from my iphone (wife in ipad)... iPhone has same results...

itunes library is large with music, but only have 30 or so videos...

This is what I see when I tap on home sharing/Mac Pro:

Ditchey MacPro._home-sharing._tcp.local.
iTunes Home Sharing

Ditchey-MacPro.local:3689
10.0.1.6:3689
fe80::225:4bff:fe87:3486%en0:3689
2604:2000:1090:c01c:225:4bff:fe87:3486:3689

Database ID = 7432E31458D932BF
dmv = 131082
hC = 73a9fc96-8fb4-4820-b00b-ece3cee88a33
hG = 00000000-02c6-0f04-2f78-b508dbb74f37
hQ = 1322
iTSh Version = 196618
Machine ID = E7051911BED2
Machine Name = Ditchey MacPro
MID = 0x930A89C32888741B
OSsi = 0x1F5
PrVs = 65538
txtvers = 1
Version = 196620
 

priitv8

macrumors 68040
Jan 13, 2011
3,631
476
Estonia
That one looks normal.
Does your Pro hold the library on internal drive(s) or needs it to connect to external or network drives for this?
Are you sure you just hadn't temper to wait until the library gets cached by iOS?
PS imho the iOS 7 version even shows a progress indicator while doing this.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.