stubborn trash

Discussion in 'Mac OS X Lion (10.7)' started by vchampea, Dec 20, 2012.

  1. vchampea, Dec 20, 2012
    Last edited: Dec 22, 2012

    vchampea macrumors newbie

    Joined:
    Jan 20, 2010
    #1
    I can't believe I let this happen again. I have an external HDD formatted to NTFS. Before I always had problems deleting files from it on my mac. When I tried to delete files from the external HDD on the mac it would go to the trash and then when I would empty the trash I would always get errors or I would get a message saying the file is in use. I actually got help from a guy on another forum who used Remote Desktop and tried every trick in the book to get that trash emptied. He booted the mac in some kind of special mode, used the terminal, secure empty trash... I don't even remember all the things he tried. In the end he couldn't delete the files. He could just make them invisible. And the file size was 0 bytes so it wasn't taking up any space. I didn't actually get rid of the files until I formatted the HDD.

    Well it's happened again. I promised myself that I wouldn't try to delete anything from the external HDD from my mac but I thought it would be ok a couple of times. Now I have two files that are permanently stuck in the trash. I don't get any kind of message when I empty the trash. When I hit empty trash it makes the sound but the two files always remain. I have the program Trash It, which doesn't help. I don't know what to do. I don't understand why the trash in Mac OS has to be such little b****.
     
  2. -Concept- macrumors member

    Joined:
    Dec 11, 2012
    Location:
    In front of a computer. Any computer.
    #2
    Be careful.

    Try to force empty the trash using terminal:

    Code:
    rm -rf ~/.Trash/*
    You can also hold option while emptying and see if that helps, or right clicking on each individual file that won't disappear and hitting 'empty trash.'
     
  3. vchampea thread starter macrumors newbie

    Joined:
    Jan 20, 2010
    #3
    Using the terminal got rid of some of the stubborn trash that was stored on the local disk, but it's not helping at all for the files stuck on my external HDD. I tried holding option and clicking each file individually. No luck :(
     

Share This Page