Stuck at boot with spinning wheel for hours

Discussion in 'Mac OS X Lion (10.7)' started by vir2L, Jul 21, 2011.

  1. vir2L macrumors newbie

    Jul 21, 2011

    Yesterday I made a partition and cloned my Snow Leopard in order to see if Lion worked with the software I have.
    I then booted to my "backup Snow Leopard" partition and upgraded to Lion but for some reason I'm stuck with spinning wheel for hours when doing the first restart. According from the install.log it seems that the install (upgrade) was done properly.

    30 seconds after finishing the installation I restart and in verbose mode I get this log (sorry for the lousy quality, with was taken with my mobile).


    I've tried everything.
    Repaired permissions, disk.
    Resetting PRAM, NVRAM, SMC.
    I even left the MBP all night in this process to see if there was any progress. No luck.
    Tried to enter safe mode but I only get a black screen and a new restart. (Something like PRAM)

    What could be causing this?

    In the past when I installed Snow Leopard (10.6) I had some issues with my firewire (they stopped working a few months ago).
    I needed to boot to safe mode in order to finish the install of SL and remove these files from /System/Library/Extensions


    Rebooting with this change shows that everything works properly (besides the dead firewire ports).
    I don't know if the "spinning wheel" has something to do with my FireWire or Airport (which works fine in SL).. since it got stucked in there when I look through verbose mode.
  2. byrgenar macrumors newbie

    Jan 30, 2009
    Same problem here, and same previous problem with the firewire ports (and solved in the same way on snow leopard)
    Do you know if there is a way of selectively choosing Kexts on install?

    I'll post if I find anything else out
  3. vir2L thread starter macrumors newbie

    Jul 21, 2011
    If there is I would love to know that.
    Right now I'm looking at these lines and see if it has anything to do with it.
    Well, thanks for the reply! At least I'm not the only one having this issue..

    I'll also post something If I find anything
  4. byrgenar macrumors newbie

    Jan 30, 2009
    firewire, lion and the rest


    After all manner of poking from some of the lesser minions of hell, i have come to the following conclusion.

    The Lion installer can not continue past hardware checking if you have faulty components (in my case fire wire ports on a 15" 2006 2.16ghz Macbook pro ,A1211). Snow leopard would eventually just shrug and install anyway. Lion is in this case, not so good.
    I have tried this with USB, DVD and DMG (direct download) so it's not a format issue and I eventually did get it working (more below) so it isn't a corrupt download (check sum was fine anyway).

    As a reference, for the standard instal (dmg) I left it going overnight and there was no progress (9hrs). It just cant pass the hardware check stage and move on.

    But, you can still install successfully. You need three things.

    Another mac (running SL 10.6.8, I used a 2009 macbook pro 13" but It should work with anything really, it just has to have 25gb of space)

    An external Hard drive

    Carbon Copy Cloner (newest version and donate if you can, they really really deserve it)


    Set up a partition on your macbook pro (with the faulty firewire ports etc).

    On the other (fully working mac) install lion to a seperate partition (standard dmg method)

    Use CCC to clone the Lion partiton from the working mac to the USB HDD (size doesn't need to match but you will need 10Gb or so I guess). Under clone settings remove IOfirewire kexts from system-library-extentions. Ignore warnings;)

    On faulty computer, clone Lion partition from usb to internal hard drive.
    (you could just delete the kexts here if needs be (pre boot).

    Voila working Lion install.

    I wish I could bill for the waste of time and sheer frustration of having to piss around with this stuff but I've done so much of it through the years, and they always ignore the invoice.

    All the best and good luck
  5. distortedloop, Jul 21, 2011
    Last edited: Jul 21, 2011

    distortedloop macrumors 6502


    Jun 29, 2007

    I'm having the same problem. I have the same error message in my verbose screen mode. My firewire ports work, though.

    There should be some way to get a message of what the actual error is.

    I'm not interested in going the path of making a clone of another system; too much resetting up of the machine down that road.

    Here's a thread I started before seeing yours. Nothing in it useful other than I've tried different drives and PRAM and install disks.


    Attached Files:

  6. distortedloop macrumors 6502


    Jun 29, 2007

    Hmmm...I wonder if this twist on your method would work. Clone my Mac Pro's SL drive to an external. Boot off that external on my MacBook Pro. Install Lion on external SL drive with the MacBook Pro by pointing the installer at that drive. Clone over that external to my Mac Pro.

    Like you, frustrated over all the hours spent on these "it just works" machines over the years. LOL. Not sure Lion's worth the effort at this point for me, but I'm stubborn and don't like to fail. Not sure I have the emotional energy to deal with those hoops this afternoon, though.
  7. vir2L thread starter macrumors newbie

    Jul 21, 2011
    Finally!! I'm currently using Lion on my MBP.

    I've used your method.

    Installed on an external drive and updated from another macbook.
    After that I cloned the partition (without the FireWire kext files) with CCC to my MBP and... voila! :))

    I don't know if there's another method but this one is working! :D
  8. robertgmartin macrumors newbie

    Dec 17, 2011
    This Fixed it for me

    I have a few Helpful Tips for successfully installing Lion on my Hackintosh

    GA-Z68X-UD3H-B3 F9
    i5 2500K
    16GB Ram
    ATI Radion 4850 512Mb

    I had several issues when attempting this and scoured the Forum for solution to a couple of issues:

    Issue 1 - Spinning Wheel at Install
    I could not get past the Spinning wheel at the install scree no matter what I tried i.e. -v -x GraphicsEnableer=No etc. etc.

    Solution: Enabled the On-Board Graphics Adapter (Intel 3000) and hooked my monitor up to that and re-ran the install - All Worked Fine after that. Ran MultiBeast 4.2(Lion Version) at the end and went back into the Bios and re-enabled My PCIe card and hooked my monitor back up. Smooth Sailing

    Issue 2: No APP Store Login as My Ethernet Port was not appearing under my Network settings. My Wireless adapter was there but I could not get my Ethernet Port to appear no matter what I did. I put a different Hard drive in with Windows 7 Pro and started the PC, Still no Gigabit Ethernet Port. I thought OK, maybe the port fried and I have to RMA the MB. That would Suck.

    Solution: Note: Before I installed Lion I flashed the Bios to F9 and then reset all of the settings to the recommended settings for Lion. Lion would install (after the above Graphics solution 1 was employed). But my Ethernet Port would still not work and I could not login to the App Store. Ok, so what I did was go into the BIOS and used the Default Bios settings by selecting use "default Bios settings" Or the Safe settings (can't remember the exact terminology now). I restarted the PC and of course, I could not boot into OSX. After boot up failed, I held down the Power button to shut the Computer down and then powered int back on and went into the BIOS and reset to the recommended Lion Settings (they are posted everywhere here in various guides so I won't list them here) and Viola!! my Ethernet adapter appeared when I went to add an adapter under the Network icon in "Settings".

    I hope this helps someone else. I also want to thank many many contributors to this forum as I have learned so much and am trying to give back just a little.

    Peace Out.


  9. cyclotron451 macrumors regular


    Mar 16, 2005
    Also Mountain Lion 10.8.2

    This advice of yours has just repaired an iMac (which I'd been using happily in Lion, and Mountain Lion, but) which failed spectacularly - and remained failed for 3 months no matter what I tried - when the 10.8.2 upgrade hit. It 'installed' 10.8.2 but never ever successfully rebooted.

    Also in this case the FW400 port is slightly faulty, a student managed to insert a FW400 cable upside down into the connector - giving a small puff of smoke! I think it has an intermittent fault, which became 'mittent'/permanent under ML 10.8.2, an upgrade too-far!

Share This Page