Stuck Boot Issue with GTX 680 (both Mac and Non-Mac Versions)

Discussion in 'Mac Pro' started by bsbeamer, Jun 26, 2013.

  1. bsbeamer macrumors 65816

    Sep 19, 2012
    I have a Mac Pro 5,1 running OS X 10.8.4. Recently tried using a GTX 680 non-EFI (PC version) and was running into numerous issues after about a week of use where the machine would not boot. Decided to return the card and get the EVGA GTX 680 Mac Version (with EFI/boot screens). Went back to the stock 5770 card in the meantime and there's no issues at all.

    Installed the GTX 680 Mac Version card last night, and as had the same exact issues as the PC version, but this time I could see what was happening... Machine was getting stuck at the grey Apple logo screen and the small rolling progress circle would "get stuck" right before it would load the log-in screen/desktop.

    I'm fully able to boot into recovery mode, select partitions, and run utilities with both keyboard (usb) & mouse (bluetooth) functionality. I have repaired permissions on the boot drive, but no changes after. Tried booting with my HDD clone and the same thing happens.

    Everything on the machine appears to be working. Swap in the stock 5770 card, everything works completely fine. Swap back the GTX 680 card, and it works fine the FIRST boot time only. After that, it gets stuck in this endless stuck on grey Apple screen.

    Installed the NVIDIA 313.01.02f01 driver - and was working until shutdown/restart.

    Called EVGA and they said to call the retailer I purchased the card from and are offering to RMA the card. The retailer says call EVGA. I'd take it into Apple, but since it's technically a 3rd party card, I'm sure my support will be quite limited.

    The card appears to be "working" fine (as in outputting a display signal), and this looks like it's a driver or software related issue. Fairly sure this is not a defective card... have not run into this issue on any machines I've worked on recently with GTX cards.

    Has anyone ever experienced this issue with a GTX 680 card? Any recommendations before I try reinstalling OS X 10.8.4?
  2. tony3d macrumors 6502

    Apr 6, 2006
    Did you try doing a power reset, and zapping the Pram?
  3. bsbeamer thread starter macrumors 65816

    Sep 19, 2012
    Yes, numerous times with both boot and clone drive... same results.
  4. tony3d, Jun 26, 2013
    Last edited: Jun 26, 2013

    tony3d macrumors 6502

    Apr 6, 2006
    Go into Preference, and trash the desktop pref's, finder, and system. I had the same problem once. After trashing the mentioned files, zap the Pram on the first reboot. This worked for me. You may as well repair permissions while your at it.
  5. GP-SE macrumors 6502

    Feb 27, 2013
    with the card installed, try to download and install the combo 10.8.4 update, this overwrites some files, and may fix the issue.
  6. chris.k macrumors member

    May 22, 2013
    I've had a similar problem a few times where the grey login screen is unresponsive (or so I thought). It's actually responding, but you can't see what you're typing.

    I then did VNC/screen sharing from my MBP and brought up the login screen remotely. I was able to login properly from there.
  7. bsbeamer thread starter macrumors 65816

    Sep 19, 2012
    No luck with trashing preference files and PRAM reset. Also tried hooking drive up to another computer to rebuild directory structure (DiskWarrior) and verify everything. Still no luck. 5770 card is still booting 100% perfectly fine...


    Can't even get the machine to boot with the GTX 680 card installed anymore. Doesn't look like this will be an option, unfortunately. May try to install the combo update with the 5770 card and then swap the GTX 680 - unlikely it'll work, but worth a shot.


    This is an EFI version card - the GTX 680 Mac Version. The official EVGA product. No screen problems, and see everything that's functioning at all times... the issue is the boot screen is hanging up - the circular progress "bar" is rotating and then freezing before logging in or showing the login screen.

    I cannot access via VNC or Screen Sharing - the system is not getting past the boot freeze. Not even prompted to select user name or guest, so unlikely it's a bad user account either.


    Currently attempting a clean install of OS X 10.8.4 on an erased and repurposed "spare" drive (transferred a lot of stuff off of it last minute). Will see if this can at least get booting. Really would like to avoid reinstalling all software and "setting up" all over again, especially since the 5770 card is working 100% fine on this machine...
  8. MacVidCards Suspended

    Nov 17, 2008
    Hollywood, CA
    Do you have any other Mac OSX installs that could be tried as boot disk?

    A MBP in target mode via firewire or even a SATA drive via USB.

    Then if problem persists with completely different OS install, you know it is hardware.

    Does your card show all 16 lanes showing up at PCIE 5.0 ?

    If fewer than 16 lanes show up, there may be a bad connector in PCIE slot or trace.
  9. bsbeamer, Jun 26, 2013
    Last edited: Jun 26, 2013

    bsbeamer thread starter macrumors 65816

    Sep 19, 2012

    Didn't have a spare OS X installed drive that I could use, and didn't want to mess with the MBP's system drive right now... (at least this is working!)

    Just finished a clean install of 10.8.4 - fresh download this AM, installed via USB stick created via Disk Utility. Installed on a completely erased and reformatted/partitioned drive with the GTX 680 Mac Version installed. Install worked flawlessly. Machine is running "barebones" OS X 10.8.4 completely fine. No issues with basic functionality at all.

    Did not perform any data migration. Not sure if I will, even if I need to resort to using this clean installed drive.

    No further drivers or updates have been installed yet, but via system information (version 10.8.1) card is showing as:

    NVIDIA GeForce GTX 680
    Type - Display Controller
    Driver Installed - YES
    Slot - Slot 1

    NVIDIA GeForce GTX 680
    Driver Installed - No
    Slot - Slot 1

    In additional info, showing link width as x16 and 5.0 GT/s.

    So card completely appears to be working, as I originally suspected. Display outputs were functioning 100% previously, but booting was creating the issue. It would not get to the "login" screen and appeared to be freezing immediately before that quick "flash" where the circle progress bar disappears (with the Apple logo remaining) and then the login screen appears.

    Have shutdown, waited, and restarted this machine four times so far with the fresh install. Each time it's worked fine and functions as it should. So it's likely a software or driver issue on the original install... will likely try to troubleshoot it some more before giving up on it and moving to setting up this fresh install.
  10. bsbeamer thread starter macrumors 65816

    Sep 19, 2012
    Update: Apple Care phone support was basically stumped. Asked which graphics card this was numerous times and needed to give them the P/N number before they believed it was a "Made for Mac" card.

    They were tossing the problem around to a lot of people with numerous suggestions that have already been tried - reset PRAM (does nothing), verify disk permissions (no errors), and safe boot (which fails and locks up). Then was given a higher level support person who basically said to perform a fresh/clean install (which has already been done, and works).

    At the point in which the lockup occurs, Apple support seems think the issue is a failed or corrupted boot-loader. (Thought that was only for hacked installs on non-supported machines?!) Suggested to perform a re-install of OS X on top of the drive with the issue using the 10.8.4 USB drive installer I created earlier (or through the 10.8 recovery partition and update download, but that would take 1.5 hrs+).

    Performing the reinstall now with fingers crossed.

    If it fails, I'll resort back to the fresh/clean install version and will attempt to use the migration manager. (I'd love to avoid re-installing software and plugins!)

    Then if that fails, or creates the same issues, I'll go back to a fresh/clean install and setup from scratch.
  11. Dr. Stealth macrumors 6502a

    Dr. Stealth

    Sep 14, 2004
    SoCal-Surf City USA

    That is exactly what I would have suggested. And I'll bet it works !

    A re-install actually does a clean install but keeps your files and settings....

  12. 666sheep macrumors 68040


    Dec 7, 2009
    Try verbose mode to see what it tries to load when it hangs.
    My presumption: something wrong with Nvidia drivers, especially if 5770 works.
  13. bsbeamer thread starter macrumors 65816

    Sep 19, 2012
    The re-install of 10.8.4 on top of the troubled drive appears to be working! Had to uninstall the NVIDIA driver and reinstall it - system was saying the driver/software was incompatible, despite being 10.8.4. (Guessing that one of the files that NVIDIA writes during the install was overwritten by the 10.8.4 re-install.) Have restarted machine several times and has been operating as usual it seems.

    Will test and put through paces later tonight when I get a chance. Plan on holding onto the less than 10GB clean 10.8.4 system install that was working - will clone to a small partition, just in case.

    Thanks for the help and feedback - will update with any further info.
  14. bsbeamer thread starter macrumors 65816

    Sep 19, 2012
    Never had to try and never had a reason to try until now, but it was a welcome change from the overwrite everything approach of previous OS versions. I'm guessing this is a feature new(er) to Mountain Lion? Was never available for the 10.5.x and 10.6.x installs on several of the Mac Pro's I've worked on previously.
  15. netkas macrumors 65816

    Oct 2, 2007
    I've noticed my efied gtx680 would stuck macpro on boot if there is no display connected to the card
  16. bsbeamer thread starter macrumors 65816

    Sep 19, 2012
    Had a display connected and was getting a live output signal the entire time. Was actively able to see the boot, select boot drives when holding option, etc. Issue came down to an issue with OSX and the boot itself - likely a bad bootloader that was either corrupted or failed for some reason. The issue did not present itself with the stock 5770 card at all.

Share This Page