Stuck CD Tray

Discussion in 'Mac Basics and Help' started by doweha, Dec 25, 2009.

  1. doweha macrumors newbie

    Joined:
    Nov 20, 2009
    #1
    Hi guys, sorry if this has been posted before, I've just searched through the forums and haven't found anything on it.

    My CD tray is stuck in my powermac G5, I keep pressing the button to eject it on my keyboard but nothing happens, I've tried restarting it. Unfortunately there isn't a CD in the drive so I can't drag the icon to the trash which is what the apple support site said, but I just want to open the drive to put a CD in, any ideas? All the keys on my keyboard work fine except that bloody eject button. Its one of the older keyboards, not the flat ones that you get now, its the version before that. Thanks, Happy Christmas!
     
  2. angemon89 macrumors 68000

    angemon89

    Joined:
    Feb 5, 2008
    Location:
    The place where Apple designs stuff
    #3
    Don't know if this trick works with PowerMacs but it does work on Macs with the slot loading drives. Turn off your PowerMac and upon startup hold down your mouse button for about 15-20 seconds and the CD will pop out.
     
  3. doweha thread starter macrumors newbie

    Joined:
    Nov 20, 2009
    #4
    Thanks for the replies guys, I've tried holding down the click on the mouse and had no luck with that, so I then went into Open Firmware and tried to eject the CD through that, and in the prompt it said 'can't open CD Drive'. So I know that's obviously a bigger problem than I thought it was, to be honest, this CD drive is rubbish and I wanted to replace it anyway, I just wanted to know is this a driver issue, hardware issue or OS issue? Because I don't want to get another disc drive in there and to have the same problem, has anyone got any ideas? Thanks for all your help
     

Share This Page