Stuck downloads in Launchpad after updating to Yosemite

Discussion in 'OS X Yosemite (10.10)' started by aces2, Aug 2, 2014.

  1. aces2 macrumors newbie

    Joined:
    Dec 28, 2010
    #1
    I upgraded to Yosemite while an iMovie update was paused in Mavericks, now the icon for iMovie cannot be deleted, restarted, etc... and, it's a blank icon space. What's even worse is now the launchpad icon always shows a download to be in progress. Installing iMovie fresh from the App Store works, but now that icon, a second "iMovie" icon, still has a download bar beneath it even though it fully installs. The original broken icon stays visible within Launchpad and cannot be removed.

    [​IMG]

    I also do not have a backup of my computer prior to installing Yosemite, only after. Dumb I know, but I purchased a Time Capsule the same day as the release and was too impatient to do the gigantic initial backup before installing Yosemite. Otherwise I'd reinstall that backup with Mavericks running, resume the update to iMovie, then reinstall Yosemite.

    If anyone has any idea how to fix this, I'd be grateful. I do not want to wipe and start from scratch, but this is the kind of thing that will eventually push me to it.
     
  2. twistofmatt macrumors member

    Joined:
    Aug 17, 2013
    #2
    I am having a similar issue, so I ran the command

    rm ~/Library/Application\ Support/Dock/*.db ; killall Dock

    that usually took care of a messed up LaunchPad, but it didn't rebuild me a new .db file for LaunchPad so I could try an third party app like LaunchPadCleaner.

    Did Yosemite move the launchpad database?

    EDIT:

    http://forums.macrumors.com/showthread.php?t=1758631

    Just found that thread.
     
  3. aces2 thread starter macrumors newbie

    Joined:
    Dec 28, 2010
    #3
    Oh man! Worked! Thanks man, I can't believe I didn't find that thread after all my searching.
     
  4. MarvinK9 macrumors newbie

    MarvinK9

    Joined:
    Jun 6, 2014
  5. stefanradev macrumors newbie

    Joined:
    Mar 8, 2010
    Location:
    Bulgaria
    #5
    Worked for me!
    Thank you! I have tried so many things today! :D
     

Share This Page