Stuck in DFU mode - itunes cannot find device

Discussion in 'iPod touch' started by rt110, Aug 24, 2012.

  1. rt110 macrumors newbie

    Joined:
    Aug 24, 2012
    #1
    So...
    I wanted to reset my ipod touch before giving it to my kids, so I used the reset function in the settings menu to wipe it.

    But after waiting a while I found the ipod showing the 'connect cable to itunes' picture, however the device was not detected by itunes although it was plugged in (and I tried a second cable, and a second mac, just to make sure).

    So I manually put the device into DFU mode using the home and power button, and now the device is showing a blank screen and is as lifeless as can be.

    But it is still not detected by itunes, so I cannot ask itunes to restore the software. Has the ipod gone? Is it fit only to be buried? Itunes is up to date, and I have tried on another machine as well, and have tried a spare cable.

    If anyone has had a similar issue and figured out a solution I'd be very grateful!
     
  2. lucasapple macrumors newbie

    lucasapple

    Joined:
    Aug 24, 2012
    Location:
    New York
    #2
    I've had that happen to me a couple times! Try holding down both the power button and the home button until the Apple logo shows.
     

Share This Page