Stuck in DFU mode, no getting out?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MrMacBooky, May 5, 2008.

  1. MrMacBooky macrumors newbie

    May 5, 2008
    After my battery drained this weekend, I am kinda stuck after attaching it to my macmini again. It booted once saying it needed repair, then restored and after that it and i were f:eek:ck:mad:d

    Biggest problem at this moment is that i'm stuck in DFU....
    after restoring to 1.1.4 in iTunes it will either never finish restore and get stuck during software validation (at the end) or i get an error (sometimes 9, 6 and/or 1604)before that. The screen looks awfull (all kindsa stripes etc..:confused:)
    In all cases all i can do is shut off with home/sleep and reattach it, after which it is still in DFU in iTunes.
    Some help would defenitely be appreciated

    btw, tried different systems, different users, different jailbreakprograms etc...basically tried it all except for the right solution :eek::mad:
  2. TheFlamingHips macrumors newbie

    Jun 1, 2008
    Stuck in DFU mode

    I'm having the exact same problem as MrMacBooky... I'm getting the same errors. I've tried getting out of DFU mode in iNdependence, iPlus, PwnageTool, ZiPhoneOSX, iBrickr...etc I've tried restoring to 1.1.1, 1.1.2, 1.1.3 and 1.1.4 iTunes. When I try iNdependence it says: iPhone in DFU mode... and won't get out of it.. When I try iBrickr it doesn't even see the phone.

    I've tried restoring in iTunes on my PC (XP), and two different macbooks.

    I've hacked the iPhone since the first day it came out, so I don't consider myself a novice.. But this one has really got me??!!!

    I get errors: 9, 6, 1618, 1600 and sometimes iTunes says: waiting for iPhone and my iPhone has a frozen screen.

    I'm in Australia so I can't take the phone into the Apple store for a replacement.

    Any help guys?


  3. carlosjcardona macrumors newbie

    May 27, 2008
    Stuck in RESTORE/DFU


    I am having the same problem. My 1.1.4 phone is permanently stuck in recover state and when I try to restore it with ITunes the phone hangs on the screen with the white apple logo. ITunes meanwhile waits for the phone to respond.

    I have tried all sorts of firmware to restore it to, as well as running Ziphone, IBrickr, ILiberty to bring it to normal state. I originally jailbroke with Ziphone.

    Any help will be greatly appreciate it.


  4. Ojsakila macrumors newbie


    Jul 6, 2007
    are any of you guys with AT&T? If not, you might be out of luck. In dfu mode, iTunes should see the phone the phone and start the restore. Its sounding like you guys have "unlocked" phones...
  5. rogierjaarsma macrumors newbie

    Jun 17, 2008
    same problem!!!


    did anybody solve this problem?


  6. carlosjcardona macrumors newbie

    May 27, 2008


    Yes, my phone is unlocked. In my case, ITunes recognizes the phone and provides the option to restpre. It then proceeds to check online and gives the option to "restore and update." It then prepares the phone (Iphone screen goes blank). But then as the phone is "preparing" it simply hangs there. The phone screen shows the white apple logo and the small round "thinking" dial.


  7. rogierjaarsma macrumors newbie

    Jun 17, 2008
    stuck in dfu mode

    hey carlos,

    The same is happening to me. It tries to restore and you will see the apple logo with the wheel, but it never finishes? When I restore to a different firmware, instead of 1.4 it shows a white screen, or black with white stripes.

    Did you have the same problem? And how did you solve it?


  8. carlosjcardona macrumors newbie

    May 27, 2008
    Reply to Rogier

    Hi Rogier,

    I have given up and will see if I can claim warranty from Apple. I tried most jailbreaking?unlocking programs available online, tried different computers with different systems, tried different firmwares. The phone is bricked.

    If Apple cannot fix the problem I will keep it hoping for a future fix.

  9. Sherpagames macrumors newbie

    Jul 2, 2008
    did you ever find a solution for this? i have exactly the same problem and after spending 48 hours working on it i am just about to give up.
  10. rogierjaarsma macrumors newbie

    Jun 17, 2008
    no solution

    I haven't found a solution yet...

    I will send mine back to apple...Probably it's a hardware thing. A bad connector of some kind.


  11. carlosjcardona macrumors newbie

    May 27, 2008
    Genius at Work


    Yesterday I dropped my Iphone at Apple and by Saturday I should have an answer from a Genius. I will let everyone know.

    Keeping my fingers crossed,

  12. carlosjcardona macrumors newbie

    May 27, 2008
    New phone from Apple

    Hi Everyone,

    I am happy to say that Apple checked out my phone and issued a replacement under warranty. I inquired what the issue was and quite frankly I was not given an answer: "we do not repair Iphones anymore....". The rep probably meant first gen units.

    Anyway, I justed jailbroke and activated the unit with ILiberty and finished syncing all my old stuff. Right now I am roaming on T-Mobile and ATT and when I go back to Costa Rica it should work with I.C.E., our only mobile and landline telecom.


  13. Sherpagames macrumors newbie

    Jul 2, 2008
    just to close the loop on this - I could not get my phone working so i went to the apple store and they replaced it with a new one this weekend! it truly was bricked!
  14. lucifiel macrumors 6502a


    Nov 7, 2009
    In your basement
  15. legomaster100 macrumors newbie

    Oct 10, 2010

    i have a jailbroken ipod touch 2g running 4.0 and tried to rejailbreak using sn0wbreeze 2.0.2 then after the ipsw was complete i put it in dfu mode to restore/update now i want to update to 4.1 and it takes 30 mins to download by the 17 min mark my ipod reboots itself to the recovery mode logo and after the download it sais it was not able to complete the download and my ipod timed out!! please help ive tried to download softwares frome the internet then i shif restore in itunes and after the variation with apple it sais could not e completed
  16. mikness360 macrumors newbie

    Dec 28, 2010
    My ipod 2g 4.1 jailbroken was stuck in dfu after updating it to 4.2 BUT I SOLVED THE PROBLEM!!!!! I USED ANOTHER PC TO RESTORE THE DEVICE AND IT WORKED!!!!!!!!easy and simple guyzzzz!!!

Share This Page