Stuck in MacOS upgrade pergatory

Discussion in 'macOS' started by solinari6, Jun 22, 2017.

  1. solinari6 macrumors member

    Joined:
    Aug 13, 2008
    #1
    I'm having some problems I hope someone can help with.

    My mac has been acting really stupid lately, so I did some poking around, and noticed I was still on the first beta of Sierra (12). So I figured I'd upgrade to the latest High Sierra beta. I followed the instructions to register my mac and all that jazz, and it said that the upgrades I was eligible for would show up in the mac app store. Well nothing did.

    So I figured maybe I need to upgrade to the Sierra release version first, then it would let me upgrade to High Sierra. So I downloaded the full version of Sierra, and ran in the installer. It thinks for a while, and does the "We're around to reboot, hold on!" thing. Then it all shuts down.

    Then .... nothing. Screen stays black for HOURS. Monkeying with it, I can see it IS on, the keyboard is on, and funny enough, the mouse floats around on the black background. But nothing is happening. It's pretty much bummer city, man.

    So I hold down the power button to force it to shut down, and then restart it. It finally does come back up, but is still at Sierra Beta 1.

    I tried this all again, and it just did the same stupid thing. So i'm not sure how to proceed here. Anyone have any ideas?
     
  2. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    What I'd try:

    1. Download a clean copy of the Sierra installer (NOT "High" Sierra).

    2. Create a bootable copy of the installer on a USB flash drive of 16gb capacity or greater.
    This can be done with "Diskmaker X", "Install Disk Creator", or via the terminal.

    3. Boot from the flash drive installer.

    4. Go to Disk Utility and re-initialize the internal drive to HFS+ with journaling enabled.

    5. Try to install from the Sierra USB installer.
     
  3. solinari6 thread starter macrumors member

    Joined:
    Aug 13, 2008
    #3
    Thanks for the advice! I was just in the middle of trying one last thing when I read that...

    I unplugged the 2 external monitors from the macbook and tried again ... looks like it is working this time. Strange!
     

Share This Page