Stuck in Recovery mode after interrupted upgrade

Discussion in 'iPhone Tips, Help and Troubleshooting' started by hMMSTER, Feb 22, 2011.

  1. hMMSTER macrumors newbie

    Joined:
    Feb 22, 2011
    #1
    Okay, so here's my problem.
    So, yesterday I bought a used iPhone 3g, for half an hour or so I was stuck on the pineapple screen, possibly just because that was my first experience with an iPhone.

    Now, when I finally got it in DFU mode, I connected it to a computer to upgrade from iTunes, this went well, until the update was interrupted since the laptop ran out of power.
    After this, the phone would boot to an apple logo.

    Now, third time, I tried upgrading again, this time, my dad pulled the chord out in the middle, and now whenever I try to upgrade (Even in DFU mode) I just get a 1015 (Trying to downgrade) error.

    Also, whenever I start the iPhone (Except when I put it into DFU, ofcourse) I get stuck on the recovery screen, I looked up how to get out of it, but it doesn't work. Appearently I'm in a "Recovery screen loop".

    Now, what should I do? Is my phone unusuable now?
    Also, the previous owner resetted it, so it's not jailbroken.
     
  2. hMMSTER thread starter macrumors newbie

    Joined:
    Feb 22, 2011
  3. Davvido macrumors regular

    Davvido

    Joined:
    May 22, 2010
    Location:
    Poland
    #3
    Put it in DFU mode, then restore. If you get error 1015, try kicking device out of recovery in TinyUmbrella.

    TinyUmbrella: http://thefirmwareumbrella.blogspot.com/
    DFU Mode:

     
  4. hMMSTER thread starter macrumors newbie

    Joined:
    Feb 22, 2011
    #4
    I really couldn't get this to work on Windows vista, it refused to let me press the "start recovery", even though i set it into dfu
     
  5. hMMSTER thread starter macrumors newbie

    Joined:
    Feb 22, 2011
  6. hMMSTER, Feb 26, 2011
    Last edited: Feb 26, 2011

    hMMSTER thread starter macrumors newbie

    Joined:
    Feb 22, 2011
    #7
    Ugh, I got it to work by using iReb, and it worked fine for a while.
    I then decided to jailbreak using Redsn0w, and in the guide I saw, it told me to restore to 4.2.1, now, foolish as I was, I thought that I could just do that and get it out with iReb again, now, ofcourse I got into a recovery loop again, but this time, iReb doesn't work!.
    What shoudl I do? D:

    EDIT: Never mind, forgot to downgrade to 4.1 first, it works again now, thanks. =P
     

Share This Page