Stuck in restore. PLEASE HELP!!!

Discussion in 'iPod touch' started by lynkynpark86, Jan 26, 2011.

  1. lynkynpark86 macrumors 6502

    #1
    I am trying to restore my iPod touch (2g), 4.1 firmware (jailbroken). The restore went smoothly, until it was almost done, and now it is, and has been stuck on the screen with the apple logo and the progress bar, which is almost finished. The "Restoring iPod Firmware" progress bar in ITUNES is also stuck, and almost at the end, just like on the iPod. My iPod IS jailbroken, but I don't know what might be causing it to stop like that. Anyone know how I can fix this?
     
  2. LeighAnna Jones macrumors 6502

    Joined:
    Oct 7, 2010
    #2
    1. Power off the Itouch. Disconnect from the computer.

    1. Insure that you have the latest Itunes.

    2. Press and hold the power AND the menu button.

    3. When the Apple logo appears, let go of power but keep pressing the Menu button. As soon as the apple comes up, Count to 10 seconds exactly.

    4. Plug in the Ipod and if Itunes doesn't open by itself, then open it from the Start menu on your PC.

    5 . You should get a message that the IPOD is in restore. Hit the restore and it should update.
     
  3. walterwhite macrumors 6502

    walterwhite

    Joined:
    Jan 22, 2011
    Location:
    South Central PA
    #3
    You may want to try doing the above with it already plugged in... also if you see the apple logo on the ipod screen wait 1-2 seconds before letting go of the power (sleep) button.
     
  4. lynkynpark86 thread starter macrumors 6502

    #4
    I already tried that. I tried to restore and update 4 times, and it still isn't working
     

Share This Page