iPad Stuck in "Update Available" in App Store, even though app has updated (grrr)

Discussion in 'iOS 8' started by JulesK, Oct 25, 2014.

  1. JulesK macrumors 6502

    Joined:
    Dec 17, 2002
    #1
    At first I thought that this was a problem with an app, but now I think it's a problem with iOS 8. On several of occasions after updating to iOS 8 (now on iOS 8.1), the app store icon on my iPad Air will indicate that an update to an app is available even though the app has been updated (e.g., I saw it happen when I updated via iTunes on my Mac). The app will show in the "Updates Available" section when you press updates in the App Store on the Air. No mater what I've tried (power off/on, reboot/restart, sign out/in of iTune & App Store, etc.), still has the same issue.

    Deleting and reinstalling the app (or apps) that have "Updates Available" solves the problem, at least temporarily, but that gets old. A fresh start (Erase All Data) might work, but I'd like to avoid that.

    Anyone else come across this issue?
     
  2. key2 macrumors newbie

    key2

    Joined:
    Oct 15, 2008
    #2
    Same issue with my MacBook Pro

    App Store is showing there is an update available for Apple Remote Desktop 3.7.2 which I know is already updated to this version, when I click the update button I get the message that the update could not complete as this software is already installed.
    How do I get rid of this update message, I've tried trashing the App Store prefs and restarting but it won't go away.
     
  3. CB1234 macrumors 6502a

    CB1234

    Joined:
    Sep 20, 2012
    Location:
    Dubai, UAE
    #3
    Leave it alone, it should sort it itself out... I had the same problem, twice, but miraculously it sorted itself out when new updates became available in App store.

    I just have to say that both the times I had this problem, it was with Mapmywalk app... I wonder if a particular app is what causes this problem, although I can't see how it could....
     

Share This Page