Stuck on Apple logo screen w/ spinning

Discussion in 'MacBook' started by eisis, Jun 28, 2012.

  1. eisis macrumors newbie

    Joined:
    Jun 28, 2012
    #1
    I have a white MacBook that I tried updating today. After I went to restart and install updates, a message came up that said there was a problem installing updates. (I'm wondering if this could have happened because I was using my work's internet connection, which I always have to select from the wi-fi icon thing at the top right. It doesn't just select it automatically since it's my home computer) It prompted me to restart, so clicked on the restart button. After that it just got stuck on the Apple logo screen with a spinning gray thing like it was going to boot. After about 30 minutes, I tried just used the power down button to shut down. I then tried to power again and give it another shot. Same thing. I read on some forums to try restarting in verbose mode to see where it stops. Mine doesn't stop, it just keeps repeating the following two things: "hfs: BlockMarkFree() trying to free unallocated blocks of volume on Macintosh HD" and right after (or before) "hfs: Runtime corruption detected on Macintosh HD, fsck will be forced on next mount." Can someone please help me? I would like to try to fix it myself if I can because I can't afford to pay a tech. right now
     

Share This Page