Stuck on Apple logo

Discussion in 'Apple Watch' started by atwater, Jun 5, 2018.

  1. atwater macrumors member

    Joined:
    Jun 11, 2015
    #1
    i installed the watchOS beta 1 during the night, when I woke up it came a message on my iPhone saying that is was installed correctly, but my Apple Watch is stuck viewing the Apple logo. I have tried to hold down the crown and the button under, but it stops on the Apple logo every time.

    Someone that experience the same and have a solution?
     
  2. StumpyBloke macrumors 6502a

    StumpyBloke

    Joined:
    Apr 21, 2012
    Location:
    England
    #2
    You need to speak to Apple Care. They have pulled WatchOS 5 because of an issue like this. Are you an Apple Developer? I don’t know if they will help you if you didn’t download the beta profile from your dev account.
     
  3. atwater thread starter macrumors member

    Joined:
    Jun 11, 2015
    #3
    Thanks!

    We don't have Apple Care here in Norway, but I guess I can go to a premium reseller and have them to take a look at it.
    The profile is downloaded from my dev account.
     
  4. ricci macrumors 6502

    ricci

    Joined:
    Aug 21, 2012
    Location:
    NYC
    #4

    I’m not a dev but in the last year I had the logo stuck ( They called it a startup loop) and With Apple care, they say send it in for replacement! ( bug in the software, no fix) You can try letting the battery die! That will force it to fully restart! That’s what I did after the new watch started that again! Was able to get to the shut down screen and restart! All is good! Just know that there is no backup until you unpair ! So unpair ever few months is good house keeping! Good luck
     
  5. atwater thread starter macrumors member

    Joined:
    Jun 11, 2015
    #5
    Called Apple support today and they tipped me about removing the clock sync on my phone, after 30 seconds the clock restarted it self and did a factory reset.

    So I guess that is a workaround to that issue!
     
  6. Uhser macrumors newbie

    Uhser

    Joined:
    Jun 4, 2018
    #6
    White Apple screen of death/Stuck on Apple logo is a common problem that most iPhone users meet. People who tried to jailbreak their iPhone or upgrade their iPhone face this problem quite commonly. And, when iPhone is stuck in Apple logo, it equivalents to a toy, you can do nothing with it. Third party software like MiniTool Mobile Recovery for iOS can lend you a hand.
     

Share This Page