Stuck on boot, I need help :'(

Discussion in 'OS X El Capitan (10.11)' started by sOwL, Apr 18, 2018.

  1. sOwL macrumors 6502

    sOwL

    Joined:
    Sep 25, 2007
    Location:
    Nerd Cave
    #1
    Hello everyone. I will try to keep this as short as I can but I'm having a weird issue that I can't resolve.


    The problem:

    So, I'm getting stuck on boot. Apple logo comes up, loading bar is moving, gets up to 50-60% then stops. Once that happens, I get the spinning thing that gets animated for a while before it freezes completely. Sometimes, the apple logo and loading bar disappear and I can see the mouse cursor along with the spinning animation, but I can't move it. Unfortunately, somehow I managed to back up after the issue happened so I can't really restore. I can boot into recovery just fine.


    Things I've tried:
    • Boot in Safe Mode
    • Reset PRAM
    • Re-seat memory
    • Removed all PCI-Express cards and USB peripherals
    • Ran fsck from single user mode, also repaired disk from disk utility. No errors.

    Some background:

    I had a GPU failure suspiciously the same period this problem happened. I replaced the GPU and while video seems to be working fine (e.g recovery environment) I'm curious if something regarding the drivers is now messed up.

    This machine had been kept running headless (no monitor attached) and I used VNC to log in. It has a static IP configured and shares two drives over the network. Weirdly enough, even at this stuck state the drives are still accessible on the same IP and I can still log in via VNC but only get a black screen.


    Conclusion:

    I really need to try and fix this without resorting on a clean install. I have configured many, many things on the system level and it would take weeks of work to get it back to where it was. I have not thought about doing a verbose boot and will do so very soon (not home atm) and hopefully get a better idea of the problem. Does anyone have any ideas about what to troubleshoot next?
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    It would sure help if you told us:
    1. What kind of Mac you have
    2. What year it was made
    3. Which version of the OS you're using.
     
  3. jbarley macrumors 68040

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #3
    I think his signature line pretty much covers it.
     
  4. Sko macrumors 6502

    Sko

    Joined:
    Oct 17, 2009
    Location:
    Germany
    #4
    I've seen some machines getting stuck in the middle of the boot process, mine included. As the process differs (as you mentioned 'sometimes'), my first guess is a corrupted directory. My machine booted sometimes and worked fine, and sometimes it got stuck half way through the progress bar. I used DiskWarrior to repair the directory.
     
  5. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #5
    jbarley wrote:
    "I think his signature line pretty much covers it."

    That doesn't help us who have our preferences set so that user signatures are hidden and not displayed...
     
  6. sOwL, Apr 19, 2018
    Last edited: Apr 19, 2018

    sOwL thread starter macrumors 6502

    sOwL

    Joined:
    Sep 25, 2007
    Location:
    Nerd Cave
    #6
    @Fishrrman I thought this sub-forum was specifically for El Capitan :) Anyway, my bad. Running 10.11.6 on a MP 2,1.

    @Sko I saved a copy of dsmeg, also tried to catch errors on verbose boot but it went too fast. Is there any similar Windows software to DiskWarrior? I don't have a working OSX drive atm and I would need to try a VM I guess. Edit: Nevermind, I see I can create a disk

    One more thing to note is that sometimes, randomly, it would restart really early at boot. Most of the time it just get's stuck half way though and stays there. In the verbose boot I noticed that the last thing that gets loaded is my network configuration which is why the shared drives still work I guess.
     

Share This Page