Stuck on headphone mode

RiddlaBronc

macrumors 6502a
Original poster
Oct 14, 2013
822
496
Mcallen Tx
Well not sure whats going on but here is what happened.

I went to run earlier today and my hands get sweaty so i think that has something to do with my problems.

1st- there is a brighter spot on the right hand corner.


2nd. My speakers are not working, its stuck in headphone mode. I turn the volume up or down and it says headphones.

Could this mean water damage? I carry my phone in my hand while i jog so i am assuming sweat got into the headphone hole?

Everything works even the brighter spot. Minus the sound. I switched it off and on and same thing. I dont want to set the phone as new only to have the same problem.

Any input?
 

neutrino23

macrumors 68000
Feb 14, 2003
1,700
203
SF Bay area
This used to be an issue several generations back. Try plugging the head phones and pulling them out. Maybe plug them in, sleep, wake, pull them out. Some combination of those actions used to fix this.
 

Bacong

macrumors 68020
Mar 7, 2009
2,148
365
Westland, Michigan
this happened to my roommate's 5s. One day she was using it normally and it stopped letting her play music through the speakers and it was stuck on headphones mode. I tried everything I could to remove the supposed obstruction from the port. Compressed air, vacuum, etc.

She took it to the Apple Store and it had extensive water damage, it had even become moldy and green. She had to pay 269 for a replacement. If you can't fix it yourself, it's probably water damage.

They discovered her water damage when they removed the sim and the damage was so encompassing that it covered the entirety of the interior.
 

RiddlaBronc

macrumors 6502a
Original poster
Oct 14, 2013
822
496
Mcallen Tx
I tried compressed air and a toothpick without success. There are no apple stores near me. The closest one is about 250 miles away. I mean i could live with it. As i constantly check my phone and it still vibrates. Everything works flawlessly for now.
 

RiddlaBronc

macrumors 6502a
Original poster
Oct 14, 2013
822
496
Mcallen Tx
Well my ring tone works when i call myself.
So the speakers are good.

Wtf? When i call someone i cant hear en at all.

Well i did a hard reset twice and my sound works. Now i am afraid to plug in the headphones lol
 
Last edited:

jr866gooner

macrumors 65816
Aug 24, 2013
1,440
304
It's normal for the ringtone to sound when headphones are in. Don't give up on it. I dampened (ever so slightly!!) a piece of a cotton bud and just went to town. Next I know is it allowed me to plug headphones in and it switched back and forth no problem. 2-3 days later and the charge port on the 3 yr old ip4 gave up. Then it constantly thought it was docked!!