Stuck on internet recovery of Macbook Air mid 2011

Discussion in 'MacBook' started by lamaxx, Oct 3, 2011.

  1. lamaxx macrumors newbie

    Joined:
    Oct 3, 2011
    #1
    Hello

    It's been three days with no results for my problem bringing back life to my brand new macbook air (mid 2011)

    here's my story, and i hope someone can point me to the right direction to solving this.

    once i bought my macbook i tried setting a windows 7 partition through bootcamp, all went well and windows was up and running in parallel to OS X Lion including a shared partition formatted in exFat, then i decided to change drive letters from the drive settings in "computer management" within windows 7, i didn't realize that this would break all associations of the partitions installed when i rebooted the laptop, once i restarted the machine i had only one partition showing on the boot menu which was "windows".

    In the past several days i tried everything and eventually ended up with deleting all the other dormant partitions that are "recovery HD", "EFI", "mac" through windows management.

    I also tried running gparted to try and fix the HD but gparted gets stuck and i can't run anything, i am only able to access or reinstall windows to HDD.

    I tried using the internet recovery by holding Command+R but internet recovery shows a revolving globe for a while then i would briefly get a progress bar for a split second then the globe would change to an alert sign with the message "apple.com/support -2100f".

    I tried looking up this error message but it's not referenced anywhere on the web and i don't really know what it means.

    can someone help me in understanding what this means and how should i approach this problem.

    Thanks.
     
  2. lamaxx thread starter macrumors newbie

    Joined:
    Oct 3, 2011
    #2
    Found my solution

    I just figured out what was wrong, and I thought i would share this incase someone else needs help.

    I had two errors being reported by the "internet recovery" process, both were related to problems when connecting to the apple servers when downloading recovery tools and OSX lion.

    I was connecting to the internet through a linksys router using DD-WRT firmware.

    error "2100f" was reported when i had my 1st and 2nd DNS server setting set to use openDNS in the router.

    error "2002f" was reported when i had DHCP forwarder enabled on the router.

    the solution was simple:

    1 - I had to set the static DNS servers to google's DNS IP addresses instead of openDNS.

    2 - I Had to enable "DNSmasq for DHCP" & "DNSmasq for DNS"

    The recovery worked as expected it took around 20 minutes to download the initial recovery utility, then another 4 Hours to download OSX lion.

    Hope this helps.
     
  3. Wilfredchen macrumors newbie

    Joined:
    Oct 8, 2011
    #3
    Help

    @lamaxx

    Can u help me with the process ? I am in the same situation on my Macbook air 2011, wipe out the OS .. now stuck in internet recovery without any progress. I call up apple support Singapore but they ask me to wait till Monday or Tuesday to get reply email from Apple in Cupertino.

    Can u guide me how to do the 2 solution u post there? I am using a D-link DIR-615
     
  4. Toltepeceno Suspended

    Toltepeceno

    Joined:
    Jul 17, 2012
    Location:
    SMT, Edo MX, MX
    #4
    I know this is an old thread and I will get yeled at for resurrecting it but this helped me big time (mac mini) and I have to say thank you. Worked like a charm.



     
  5. steniosarmento macrumors newbie

    steniosarmento

    Joined:
    Jun 1, 2016
    #5
    You really saved my day! Thanks a lot!

    In my case just set 8.8.8.8 and 8.8.4.4 (google DNS servers) at the router solved the problem!


     
  6. IhateMacBooks macrumors newbie

    IhateMacBooks

    Joined:
    Jul 16, 2016
    #6
    How on earth do you complete them 2 steps? I hope its settings in the router and not the mac because even if i hold cmd + r it puts me straight into internet recovery then freezez? Please help.
     
  7. beatdis macrumors newbie

    beatdis

    Joined:
    Nov 14, 2016
    #7
    this worked for me too, thanx
     
  8. jjnz macrumors newbie

    Joined:
    Apr 19, 2017
    #8
    Thanks for this tip. Worked a gem when trying to reinstall on Macbook Air 2012. I am using an Huawei router HG630b. Went to basic settings - LAN and entered above DNS server settings in Primary and Secondary server addresses. Submit.
    No more 2002f error and Lion now installed. Cheers.
     
  9. iamtheazizul macrumors newbie

    Joined:
    Jun 7, 2017
    #9
     

Share This Page