Stuck on partition creation

Discussion in 'Windows, Linux & Others on the Mac' started by Gary123, Nov 10, 2010.

  1. Gary123 macrumors newbie

    Joined:
    May 29, 2010
    #1
    Hi everyone,

    I used to have windows 7 running on a 32 GB bootcamp partition until yesterday, wanting to extand it, I created an image with winclone, deleted the partition, but now when I want to re-create a 57GB partition thru bootcamp, it gets stuck around 30%, I gave it the whole night but it didn't progresss of a bit.

    I force rebooted, as I could not close bootcamp, nor browse any menu or open any program (I only could move the mouse around basicly).

    After rebooting, the whole 57GB disappeared, as my hard drive obviously had a failure, I booted up in single user mode (command+S on boot) and done a fsck-fy, until I get the msg everything is repaired and ok.
    When I boot back into OS X, everything seems to be fine, disk utility tells me my disk is ok. I ran bootcamp again, and I, again got stuck on the same % of the partitioning process.

    I basicly did it all twice, and I'm now out of ideas. If anyone could help me out with it...
    I use a mid-2010 15" macbook pro

    P.S : Just tried to use iPartition, but it doesn't seem to recognize the 57GB free space that I used for the partition, but disk utility and and Finder do...

    P.S 2 : I shrinked it by mistake before creating an image, not sure what that really does :<

    Thanks!
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    Try creating the partitions manually using Disk Utility, you might be able to tell where the problem lies when you try that.

    First make sure you have a good backup and verify and repair the disc from your OS X install disc.

    B
     
  3. Gary123 thread starter macrumors newbie

    Joined:
    May 29, 2010
    #3
    It still doesn't work. Tried partitioning with disk utility, no luck, even with the OS X install CD. Drive genius did not find anything wrong either.
    Time machine doesn't let back up so I can do a clean install... (fails at random points during the back up).

    ANy thoughts?
     

Share This Page