stuck on (pine)apple logo

Discussion in 'iPhone Tips, Help and Troubleshooting' started by aldorande, Apr 30, 2010.

  1. aldorande macrumors member

    Joined:
    Dec 1, 2009
    #1
    Hello all,

    since I ran out of battery today, my iPhone 3G hangs on the pineapple logo.
    I have connect it to my iMac intel to charge it, but no luck.

    I tried a reset using Home+Power button for a few seconds: same.
    Sometimes the screen displays a battery icon not charged.

    I can go into recovery mode and it is detected by iTunes 9.1
    Should I restore it?
    will I have to jailbreak/unlock the iphone again then?

    Thanks
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Charge it in the wall charger, not USB. After that, report back if you still have problems.
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    Make sure you dont restore it to official firmware cause you gonna lose your unlock.
    Charge it fully thru the wall and then try it again. Maybe run irecovery to get it to boot up again.
     
  4. aldorande thread starter macrumors member

    Joined:
    Dec 1, 2009
    #4
    I don't have the wall adapter I'll try to get it from a friend: will charge it for 1 hour and let you know how it's going

    but I have the impression that the software is damaged
    I tried to re-use blackra1n as well, that is stuck on waiting for reboot
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    If you have the pineapple then you had use pwnagetool before.
    Why go with blackrain.
    Let us know what kind of iphone you have and what firmware and unlock you were using.
     
  6. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #6
    Yeah, use redsn0w.
     
  7. aldorande thread starter macrumors member

    Joined:
    Dec 1, 2009
    #7
    I was using a mix of Pwnage Tool/Redsn0w to jailbreak it and Blacksn0w to unlock it. It's the iPhone 3G, I think I was using Firmware 3.1.2

    charging the iphone to the wall now, same issue: it still display the pineapple :(

    I go ahead and use Pwnage tool isn't it?
     
  8. aldorande thread starter macrumors member

    Joined:
    Dec 1, 2009
    #8
    - Restore from iTunes with firmware 3.1.2.
    - Jailbreak done with Blackra1n.

    The iPhone is responsive again and will charge. I will go ahead and unlock it using blacksn0w, but I'm not sure where that app is.
     
  9. aldorande thread starter macrumors member

    Joined:
    Dec 1, 2009
    #9
    My phone is operational again: it can gives call, connect to internet, run apps, etc and it retrieve my backup config.

    it's charing ok as well for the usb cable.

    the only problem is that it doesn't connect to youtube anymore
     
  10. aldorande thread starter macrumors member

    Joined:
    Dec 1, 2009
    #10
    This solution should work too once you are stuck on the Connect to iTunes logo.
    I had to restore from iTunes 9.1 since my iPhone would show the symptoms as per title

    -connect iPhone 3G and power it off
    -start RedSn0w 0.9.4 loading Firmware 3.1.2: iPhone1,2_3.1.2_7D11_Restore.ipsw

    -go into DFU mode as per RedSn0w instructions
    -click Next. that will load the jailbroken iOS into the iPhone
    -import from last backup in iTunes. The option should be given once you connect

    Then you need to fix those issues again:
    - access Youtube using iPhoneModding Pushfix
    - unlock the SIM using Cydia Ultrasn0w
     

Share This Page