Stuck! Software won't finish installing!

Discussion in 'OS X Mountain Lion (10.8)' started by PNayo92, Sep 9, 2012.

  1. PNayo92 macrumors member

    Joined:
    Jan 1, 2011
    #1
    This morning was like any other, just downloading an update that popped up in the App Store.

    Unfortunately, "The Unarchiver" application has been "installing" all day. I would turn off my computer, but doing a hard shut down could damage my disk or crash my computer...(that happened to me once, might have been a firmware update though). A window popped up saying:

    "You're computer can't be shut down now, because software is being installed. The Unarchiver is being installed. Interrupting the install may damage your computer. You can shut down when the install is complete.
    Status: Removing old files"

    It has been "removing old files" all day, I imagine.

    I need to install school software on my computer (macbook pro early 2011), but I cannot do so until the Unarchiver update finishes installing.

    I would risk the hard shut down if I had a recent computer backup, but I don't. And I'm pretty sure that the computer's inability to install the application is keeping my computer from backing up correctly.

    Does anyone have any advice?? :(
     
  2. PNayo92 thread starter macrumors member

    Joined:
    Jan 1, 2011
    #2
    problem solved. I did a hard shut down, and everything worked out.
     

Share This Page