Stuffed up my permissions...

Discussion in 'macOS' started by stallie, Apr 6, 2011.

  1. stallie macrumors newbie

    Joined:
    Apr 2, 2010
    #1
    After my MBP crashed and would not install OSX etc, I suspected a HDD failure. In went the new HD and subsequently a failed time machine install lead me to suspect a corrupted OSX. So I did a clean reinstall then dragged my old files from my old HDD that I put into a case.

    Trouble is I didn't have the right permissions to access some of my docs down the track so I did a global permissions reset yesterday...silly boy.

    For some stoopid reason, I did it on the Macintosh HDD and globally reset to

    System - R&R
    Admin - R&R
    Everyone - No Access.

    Then when I rebooted, no life, nada. So I did a reinstall of OS X and got life back, with a few niggles, the main one is that my iPhone won't sync or be registered in Image Capture.

    Any suggestions as to which permissions I need to change back? I've done the iTunes folder in Music, but that hasn't worked...

    Ta muchly.
     
  2. msjones macrumors 6502

    msjones

    Joined:
    Oct 18, 2007
    Location:
    Nottinghamshire, UK
    #2
    You can change permissions and file ownerships manually using the terminal. Google commands chmod & chown. If you have any problems just come back :)
     
  3. stallie thread starter macrumors newbie

    Joined:
    Apr 2, 2010
    #3
    Still confused.

    I'm still lost.

    I've done an OS X reinstall so permissions on the HD and library files there should be OK? Everything else seems to work fine.

    I've done repair permissions, but it only seems to fix QT and Airport Extreme problems according to the log, but interestingly lists the same problems every time I repair permissions with the disk utility.

    I've deleted itunes, reinstalled itunes followed procedures on the apple website deleting plist files, turned it off and on etc, but I still can't get the iPhone to be recognised by my computer - but it will charge happily

    My 4gb iPod is recognised no problems and syncs perfectly....

    And it's not just in iTunes, the iPhone is not recognised in Image Capture, iPhoto and Aperture in the import mode....

    I've also created a new admin user, and it is not recognised there either.

    I really really need to sync this baby. It was working quite OK - is it a massive coincidence that it might just be the phone? What to check reset there?
     
  4. darkcurse macrumors 6502a

    darkcurse

    Joined:
    Nov 5, 2005
    Location:
    Sydney
    #4
    Download this program called Batchmod. Drag the folder containing you information in it. And then change the owner to you and give yourself RWX access (just check the boxes). And then check all the boxes below. "change ownership", "unlock", "clear leopard", "apply to enclosed...". And you should be set.
     
  5. stallie thread starter macrumors newbie

    Joined:
    Apr 2, 2010
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8F190 Safari/6533.18.5)

    Thanks darkcurse, but how does that differ to cmd-I and adding me as a user and applying to enclosed?

    And I should do this to my home folder?

    Me r&w
    Everyone else no access?

    It's def not the phone. Just put it on another Mac and ok. Put another phone on my Mac and same prob.
     
  6. darkcurse macrumors 6502a

    darkcurse

    Joined:
    Nov 5, 2005
    Location:
    Sydney
    #6
    Have you copied the iPhone backups from ~/Library/Application Support/MobileSync/Backup into your new location?
     

Share This Page