Stupid iPhone battery :-(

Discussion in 'iPhone' started by cap'njack, Aug 10, 2009.

  1. cap'njack macrumors member

    Joined:
    Apr 20, 2009
    #1
    I downloaded and installed 3.0.1 and restarted my iPhone as a brand new iPhone. Charged it up fully and then used it as normal.

    Yesterday I commented that my battery life had improved drastically and I had gotten 8 hours and 27 minutes of usage and also 2 days and 1 hour of standby (by 10:08 this morning) and was still showing 100% on the battery meter...low and behold literally 5 minutes later my iPhone gave me the 20% remaining warning and then died straight after the warning.

    [​IMG]

    Hopefully the next charge will solve this but have others had issues with this at all? and would Apple change the phone becuase of this?
     
  2. STEVESKI07 macrumors 68000

    STEVESKI07

    Joined:
    Jan 6, 2009
    Location:
    Washington, DC
    #2
    Whether your battery meter is messed up or not, if you're getting 2 days of standby with 8 hours of usage and it only hits 20% then I don't think I'd want a replacement phone. I'm at 4hrs 12 mins of usage and 1 day, 2 hours of standby and I just hit 20% and I was ecstatic about that. Maybe just get an app that has a battery meter inside it? I know FreeMemory has a % meter. It's not as convenient as having it on the top but good enough to check occasionally.
     
  3. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #3
    My phone has never lasted more than about 20 hours, no matter what I've done.

    Go ahead and trade that phone in if you want to, but that seems like the worst mistake in the world to me.
     
  4. Bolo4u macrumors member

    Joined:
    Feb 16, 2009
    #4
    Similar question

    I to have the 3.0.1 update installed. It seemed to me that my general battery time has declined since this update was installed. I have used it generally the same throughout the day (with calling, apps, browsing, etc.) after the updatas before. However, I have to charge it daily, overnight.

    I just unplugged it from the charger, after an overnight (8+ hour) charge. When I went to the usagescreen, I saw this:

    [​IMG]

    Would I need to do a full wipe/restore? if so how do I reset it to a "new iPhone" as I have seen referenced in other treads?

    Thanks for your help.

    edit: I tired to ge the picture larger, but couldn't :(
     
  5. cap'njack thread starter macrumors member

    Joined:
    Apr 20, 2009
    #5
    That's about my general usage that I get. The last charge was a total fluke...I'm just hoping that the battery meter hasn't stopped working otherwise I'll have to work out how much battery I have left manually :D
     
  6. eaglesteve macrumors 6502

    Joined:
    Aug 10, 2009
    #6
    I had similar experience also, and it happened just once. The phone showed a 100% battery levels even four five six hours into heavily using it, and it died suddenly after that.

    I did not do anything other than just recharging it and re-starting it. It never happen again after that so I just ignore it as a fluke too.
     
  7. HighLife420 macrumors 6502a

    Joined:
    Jul 25, 2009
    #7
    im testing my phone right now without Backgrounder or Winterboard...

    Ive got about 30mins on use and 8 hours of stand by and my battery is at 95%..does it count Ipod as usage?

    I also switched from AsBattery to Battery control, now im hiding the battery icon and just showing %.
     

Share This Page