Stupid Leopard terminal character set -- "o" followed by "/"

Discussion in 'macOS' started by rogersmj, Dec 18, 2007.

  1. rogersmj macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #1
    Can anyone explain to me why this is happening and how to fix it (see screenshot)? It's supremely irritating when I happen to be in a directory where a parent folder ends with "o", because then it does this crap with the slash and it shifts all the text back one space but leaves the cursor out in front. This happens on both my Leopard machines.

    On a related note, what's with the fancy quotes in Terminal now? How unnecessary...is there a way to turn those off too?
     

    Attached Files:

  2. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #2
    Many you need to cut and past text from you terminal. I can't see anything in the attached image (perhaps the image got munched?) that matches what you are writing about. The sort order is normal and there are no quotes.

    If there are problems it is not the terminal program that is doing it. It is the shell. You might say which shell you are using.
     
  3. yeroen macrumors 6502a

    yeroen

    Joined:
    Mar 8, 2007
    Location:
    Cambridge, MA
    #3
    Instead of using the built-in terminal, download the free iTerm.app instead:

    http://iterm.sourceforge.net/


    It's much prettier and more feature-rich than the built-in version.
     
  4. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #4
    Odd.. I can't seem to replicate this issue.
    Does it happen when you're logged in as another user?
     
  5. rogersmj thread starter macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #5
    Look at the center of the image. Look at the last character of "indydemo/". It matches exactly what I'm writing about. Who said anything about sort order?

    I use the default terminal emulation (xterm-color) and default shell for OS X (bash). It has to be the Terminal app, because it only happens on my Leopard machines and it occurs on every machine I connect to (Leopard, Ubuntu, Red Hat, whatever).

    It happens on both of my Leopard machines on both the local system and every fracking server I'm logged into, no matter what user.

    I'll check that out, thanks...I'd still like to figure out why this is happening.
     
  6. TBi macrumors 68030

    TBi

    Joined:
    Jul 26, 2005
    Location:
    Ireland
    #6
    It seems like it's actually replacing o/ with another letter/symbol like an o which has a / through it.

    It's probably due to either the font you are using or the language you are running OSX in.
     
  7. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #7
    But it's something you're changing in your Terminal settings or fonts, which is why I asked if it happens when you're logged in as another user (with vanilla settings).

    Code:
    null:~ yellow$ sw_vers
    ProductName:    Mac OS X
    ProductVersion: 10.5.1
    BuildVersion:   9B18
    null:~ yellow$ ls -laF
    total 40
    drwxr-xr-x+ 18 yellow  staff   612 Dec 18 12:16 ./
    drwxr-xr-x   7 root    admin   238 Nov 16 17:35 ../
    -rw-------   1 yellow  staff     3 Nov 15 15:35 .CFUserTextEncoding
    -rw-r--r--@  1 yellow  staff  6148 Nov 16 17:30 .DS_Store
    drwx------   2 yellow  staff    68 Dec 18 12:15 .Trash/
    -rw-------   1 yellow  staff    56 Nov 16 17:25 .bash_history
    -rw-r--r--   1 yellow  staff    48 Nov 27 12:10 .parallels_settings
    drwx------+  5 yellow  staff   170 Nov 16 15:23 Desktop/
    drwx------+  7 yellow  staff   238 Nov 27 12:09 Documents/
    drwx------+  4 yellow  staff   136 Nov 16 17:30 Downloads/
    drwx------+ 31 yellow  staff  1054 Nov 16 17:24 Library/
    drwx------+  4 yellow  staff   136 Nov 16 15:47 Movies/
    drwx------+  3 yellow  staff   102 Nov 15 15:35 Music/
    drwx------+  4 yellow  staff   136 Nov 15 15:35 Pictures/
    drwxr-xr-x+  5 yellow  staff   170 Nov 15 15:35 Public/
    drwxr-xr-x+  5 yellow  staff   170 Nov 15 15:35 Sites/
    [COLOR="Red"][B]drwxr-xr-x   2 yellow  staff    68 Dec 18 12:15 aTesto/
    drwxr-xr-x   2 yellow  staff    68 Dec 18 12:15 aaTestO/[/B][/COLOR]
    
     
  8. rogersmj thread starter macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #8
    I've never touched the Terminal settings, except to make it white-on-black instead of black-on-white. I'd never even opened the Preferences panel for Terminal in Leopard until today when hunting for something that could cause this.

    I shouldn't be creating new users on my work machine, but I'll give it a shot on my iMac tonight. Like I said though, I haven't changed anything.
     
  9. rogersmj thread starter macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #9
    Yeah, that's what it seems to be doing. I'm using the default font for Terminal (Monaco 10pt) and I'm running US English.
     
  10. rogersmj thread starter macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #10
    OK it does NOT happen on my wife's account on the MacBook, and her Terminal and bash settings are completely untouched. I think I need to clear out my pref files or bash files and start over.
     
  11. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #11
    You appear to have a non-standard prompt. I'd start there.
     
  12. jmcdermo macrumors newbie

    Joined:
    Dec 30, 2008
    #12
    Solution?

    mrogers,
    Did you ever figure out specifically what was causing this. The same thing just started happening to me and I have a lot of terminal customizations that I'd rather not loose. I'm running 10.5.6 etc.

    It does not happen on my other accounts on the same system and while the other accounts don't have the same terminal prefs that have very similar complicated .profile files.

    When I cut and past a listing with the goofy character into BBEdit is shows up as a / followed by a return. But it's not affecting all the directories in my listing. It also happens to me when using tab completion in the terminal, but not for the whole path -- strange.

    I've attached a screen shot that shows the one home directory (my primary user) with the goofy character as well as an example of the tab completion.

    It feels like a character set encoding problem, but why it would affect only some of the "/" characters and not all of them is beyond me.

    A couple of environmental variables that may have a role:
    __CF_USER_TEXT_ENCODING=0x1AC1:0:0
    LANG=en_US.UTF-8

    Thanks,
     

    Attached Files:

  13. Chango Perezoso macrumors newbie

    Joined:
    Mar 10, 2009
    #13
    Fixed it.

    Ok, I figured this one out... it was driving me nuts too, because it affected me in Terminal and in R. It didn't matter which user account it was on my machine, which told me it was something global. And one thing that is global is the font catalog.

    Both Terminal and R were set up to use Monaco. I opened Font Book, and lo and behold there were two copies of Monaco, one with a bullet to the right of the name indicating a duplicate. I selected both files, and then Edit->Resolve Duplicates from the FontBook menu. Voila, problem solved.

    I also noticed that my most recent copy of Monaco (which shipped w/Leopard) had a minor problem during validation. I didn't do anything about this, and it still seems to be behaving properly.
     
  14. Jisuo macrumors 6502

    Joined:
    Dec 4, 2008
    Location:
    Sweden
    #14
    Just wanted to mention that Ø is a Danish and Norwegian letter. Sweden and Finland has it too but write it as Ö. :D
     

Share This Page