Stupid mistake eMac won't power on! HEEELLLPPP!

Discussion in 'PowerPC Macs' started by machobson, Aug 26, 2005.

  1. machobson macrumors regular

    Apr 19, 2005
    Hey everyone, well I made a very stupid mistake today by taking the shell off my eMac to clean it and now the computer won't power on! I know this was incredibly stupid of me and I really have no idea why I did it. I also tried powering it on with old usb keyboard with the power button on and no luck. It is warrantied under applecare. Any one have any suggestions??? Should I take it in to get looked at and lie?? I don't know what to do Im going crazy??!! plz help
  2. machobson thread starter macrumors regular

    Apr 19, 2005
    Problem solved: I forgot to hook up the wire to the Power Button lol.
  3. varmit macrumors 68000


    Aug 5, 2003
    A working Power Button usually helps.
  4. pammyspyce macrumors regular


    Jul 29, 2005
    Bay Area, Calif
    Ah, that's something I would do. Glad you figured it out. :)

Share This Page