Stupid problems with MySQL

Discussion in 'Mac Programming' started by brap, May 30, 2005.

  1. brap macrumors 68000

    May 10, 2004
    Right, so finally getting around to doing some dev work after exam silly season, and since Tiger was a fresh install for me, I need to reinstall MySQL. It's been fine in the past, but now I seem to have broken the intstaller somehow.

    After running the latest darwin 7.9 build (MySQL 4.1) installer, the prefpane reports "Server running" all the time. Except it's not. So, I gave mysql user write privileges to /tmp/, and voila! mysqld starts.

    Except it's not really. To start, mysqld performs tests to ensure it has write access to /usr/local/[..]/data - but when I run mysql_secure_installation, I get:
    touch: .my.cnf.5739: Permission denied
    touch: .mysql.5739: Permission denied
    chmod: .my.cnf.5739: No such file or directory
    chmod: .mysql.5739: No such file or directory
    . Therefore, I assume I have no write permissions to wherever it's putting those temp files.

    Except I do. It's very confusing.

    I've tried
    rm -rf [mysql folder]
    rm /tmp/mysql.sock
    and reinstalling, but the same problems keep coming back.

    Are these the only files I need to get rid of, or am I missing something? Yes, I have tried the uninstall shell script, to no avail...
  2. superbovine macrumors 68030


    Nov 7, 2003
    are you starting mysql with a 'sudo'?
  3. brap thread starter macrumors 68000

    May 10, 2004
    I got it fixed, and yeah, a sudo was involved... heh. I never did a sudo mysql_secure_installation though, rather doing all the legwork from the mysql commandline :eek:
    A hell of a lot of other messing around, too. Sigh. At least it's fixed, and was a crash-refresher course in the bowels of mysql.

Share This Page