stupid question, conflicting data on threads..help please!

Discussion in 'Jailbreaks and iOS Hacks' started by mmbo, Jan 4, 2009.

  1. mmbo macrumors newbie

    Joined:
    Sep 22, 2008
    #1
    I currently have an jailbroken iphone 3g 2.1 baseband 2.11.07. I want to upgrade to 2.2 and jailbreak it. (I dont need to unlock)
    I am planning to update my iphone 3g from 2.1 to 2.2 with iPhone1,2_2.2_5G77_Restore.ipsw and then quickpwning it to jailbreak it. I can only use quickpwn since I use windows.

    My questions is -
    1. Does it matter if I use quickpwn (windows or mac) or pwnagetool (macs only)?
    2. Does that procedure update the baseband and prevent future unlocks?
    3. Does it really matter if baseband is updated now since the Dev Team came out the yellowsn0w? There was so much warnings about upgrading via itunes to 2.2 since it will updated the baseband.. but does that not matter now?

    Thanks everybody!
     
  2. DannyBres macrumors 65816

    DannyBres

    Joined:
    Oct 30, 2007
    Location:
    UK
    #2
    1. Not at all

    2. the restore/update process in iTunes that goes from 2.1 to 2.2 updates the baseband... but you need the new baseband that comes with 2.2 to unlock your phone using yellowsn0w so that is nothing to worry about and the new baseband will give better performance.

    3. nope no reason not to upgrade now
     
  3. mmbo thread starter macrumors newbie

    Joined:
    Sep 22, 2008
    #3
    thank you!!!
     
  4. powaking macrumors 6502

    powaking

    Joined:
    Jul 3, 2008
    #4
    So then what was all the big stink on using the pwnage tool to update to 2.2 so that your baseband won't be updated? Were they able to hack the latest baseband? Confused now.
     
  5. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #5
    I believe they were able to hack the latest baseband at the last minute. Prior to that, they were sure that they could hack the previous baseband, but wasn't sure if they could hack the one that came with 2.2. So they warned people not to upgrade if you wanted to unlock. Turned out it was an unnecessary precauton, but they didn't know that at the time.
     
  6. powaking macrumors 6502

    powaking

    Joined:
    Jul 3, 2008
    #6
    That makes more sense, just never read that they were actually able to hack the latest version. thanks
     
  7. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #7

Share This Page