Stupid Question? Does UK iPhone 1.1.2 OTB work with O2 Pay&Go Sims?

Discussion in 'Jailbreaks and iOS Hacks' started by cbetta, Dec 30, 2007.

  1. cbetta macrumors regular

    Joined:
    Jul 5, 2006
    #1
    Ok, so this might be a stupid question, but I think I have looked everywhere and can't find a simple or conclusive answer.

    I have bought an iPhone here in the UK before christmas, and it came with 1.1.2, meaning it has the new bootloader. I activated and jailbreaked it to 1.1.2 but obviously couldn't use my own sim.

    So now I wanted to use it as a phone anyway, so I got a pay&go sim to use in the phone. Around the web I read people using those sims, and I hear people say that you can use a UK iphone with any O2 sim. Problem is: it doesnt work!

    The device doesn't give any errors about the sim being invalid, but I just don't get it to catch the signal or something. When I go to setting->carrier I get a "error" and a spinning wheel and nothing more. Sometimes it says "Loading" but that never leads to something useful.

    I have tried to change the "lockdownd" file, but that didn't help.


    So, either I am seriously missing something, or this iPhone just doesn't work with this SIM. Can someone tell me which one it is please?
     
  2. philgilder macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK

Share This Page