Stupid Windows Mpegs Drivig me bonkers

Discussion in 'Mac Basics and Help' started by lindmar, Mar 31, 2008.

  1. lindmar macrumors 6502

    Joined:
    Oct 31, 2003
    #1
    Got some mpegs from a friend I was going to edit up a bit.

    1 file about 700 megs...

    I can't open the files in quicktime or anything even though I have the divx codecs, the apple quicktime mpeg codec ect...

    Downloaded program called mpeg streamclip.

    Opens the file, finds there is a time code error. Fixes the error and breaks and plays the mpeg perfectly. Allows me to export to any format and the audio drops out of synch again.

    I've tried visual hub, same or worse results..

    Any ideas?

    I have no clue what they did with these mpegs, I tried opening them in Windows and windows media couldnt read them..
     
  2. lindmar thread starter macrumors 6502

    Joined:
    Oct 31, 2003
    #3

    Yeah Perian is installed.
    I'm totally baffled here, never had this much trouble with a video file...
     
  3. ewilson6 macrumors 6502

    Joined:
    Nov 30, 2006
    #4
  4. lindmar thread starter macrumors 6502

    Joined:
    Oct 31, 2003
    #5
    OK sorry should have posted all the obvious. :D

    I am far beyond installing flip4mac, perian etc.
    I've tried converting with visualhub and just about every other convertor I can think of.

    I tried separating the audio and re-synching in FCP but something is happening weird there too...

    MPEG Streamclip will play the entire clip perfectly but the moment I export, it loses sync, something happens.. Unsure what the heck these windows people did to these media clips...
     
  5. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #6
    Maybe you could post a torrent so we could download it and play with it?
     
  6. stomer macrumors 6502a

    Joined:
    Apr 2, 2007
    Location:
    Leeds, UK
    #7
    Have you tried playing it with VLC? Sounds to me like your file is corrupt, if it is, then you're going to have a hard time recovering it.
     
  7. rhett7660 macrumors G4

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #8
    Have you tried going to back to the windows environment and converting it there? Then bring it back into the Mac environment.
     
  8. lindmar thread starter macrumors 6502

    Joined:
    Oct 31, 2003
    #9
    This thing is killing me.

    MPEGStremClip does something on boot and it still plays fine.. anywhere I go, everything is in sync..

    Export and it all goes to shred.
    I tried exporting video first which gave me 18:59 seconds..
    Then I exported video on its own and it was 19:21 seconds.

    So clearly mpegstreamclip is doing something upon boot which is allowing it to play properly but as soon as I export it all goes down the tubes. Like I said, when I open in mpegstreamclip it says, we need to fix a time code error. We do that and it works. I have even been able to export into a a new MPEG which will play in VLC with working sound and in sync, but when I bring that into FCP, the sound is gone.


    I'll try in the Windows environment.

    I cant post the video as a torrent as I promised the originator it wouldnt be leaked out anywhere.. But I'm looking for help, a nice cold beer in the form of paypal for anyone who can help me solve riddle.
     
  9. stomer macrumors 6502a

    Joined:
    Apr 2, 2007
    Location:
    Leeds, UK
    #10
    Can you try the following and post back the results:

    Make sure that you have the latest version of VisualHub installed. Execute the following in terminal.app whilst making sure you replace </path/to/your.mpg> with the actual path to you problem mpg.

    Code:
    /Library/Application\ Support/Techspansion/vh131ffmpeg -i </path/to/your.mpg> -acodec copy -vcodec copy ~/Downloads/myremuxed.mpg
    
    Once this has finished, can you tell us if it has worked and if not, can you post back the contents of your terminal session?

    Also, if the file plays back in VLC then I don't see why you wouldn't therefore be able to either remux it, or transcode it successfully using VLC. Let me know if you need help doing this.
     
  10. ImNoSuperMan macrumors 65816

    ImNoSuperMan

    Joined:
    Dec 1, 2005
    #11
    Try videoredo Plus for windows(I wish they had an OSX version). I had similar problems with a video recording done on XP machine.

    Use QuickStream Fix in VideoReDo Plus. If the problem is not solved in the first attempt then go to settings and change the Audio Frame error settings. Try all the three settings and see if you get lucky with any one of them.

    It is not free but I think you can use it for a week or two in the trial mode.

    BTW what is the source of the movie? Is it a TV recording, DVD rip or what?
     
  11. lindmar thread starter macrumors 6502

    Joined:
    Oct 31, 2003
    #12
    Its a mini-dv recording which was captured to a PC somehow

    and then added to a DVD to give me.

    I'm going to try both processes here
     
  12. lindmar thread starter macrumors 6502

    Joined:
    Oct 31, 2003
    #13
    ImNoSuperMan,

    You are superman today..

    I believe your method worked.

    I need to double check but doing this, then exporting back to Mac.. Then converting to a DV file, I now have a working an in sync file to work with!

    Awesome.

    Drop me a PM with your paypal address if you have one and I'll buy you a cold one.

    Cheers
     

Share This Page