Stupid Yosemite Killed my Microsoft Office 2011

Discussion in 'OS X Yosemite (10.10)' started by cranshinibon, Nov 5, 2014.

  1. cranshinibon macrumors newbie

    Joined:
    Nov 5, 2014
    #1
    So i looked around and couldn't find any way to fix this issue. I have been trying to stay up to date on the WiFi reconnecting every 5 minutes, but this isn't the issue I'm having.

    Whenever I open Microsoft Excel 2011 on my Macbook Air running Yosemite, it crashes after a few seconds and asks me to send the report and if i want to open the saved data, which puts me back into a loop of reopening, then it crashing and so on and so on.

    Does anyone have an idea on how to fix this? I have never had so many issues with an operating system before. Please help.
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    MS Office 2011 is running just fine on both my Yosemite iMacs.

    Have you tried removing it, then re-installing the package (MS Office)
     
  3. fisherking, Nov 5, 2014
    Last edited: Nov 5, 2014

    fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #3
    all these 'yosemite killed my (puppy/battery/microsoft office/etc)' threads are a riot.

    as dhlizard said: uninstall, reinstall. and make sure you're on the latest version of office...
     
  4. tvguy, Nov 5, 2014
    Last edited: Nov 5, 2014

    tvguy macrumors member

    tvguy

    Joined:
    Jul 10, 2008
    Location:
    Las Vegas, NV
    #4
    Yeah... I not having any issue either. All is running well on my 2010 Macbook and Retina MBP
     
  5. BenTrovato macrumors 68020

    BenTrovato

    Joined:
    Jun 29, 2012
    Location:
    Canada
    #5
    Delete & re-install? Office runs fine for me but I have had one app fail in Yosemite (keeps crashing). Re-install solved it.
     
  6. baummer macrumors 6502a

    Joined:
    Jan 18, 2005
    Location:
    Southern California
    #6
    Office 2011 is fine for me in Yosemite as well. Other than it being super slow (but this is the software showing it's age), I've had no problems with Office 2011.
     
  7. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #7
    Update Office 2011, if you're anything like my wife she will have non app store updates for weeks to months.
    Thank goodness for those that can now auto-update.
    I believe she was 2-3 updates behind. SMH.
     
  8. randomgeeza macrumors 6502

    Joined:
    Aug 12, 2014
    Location:
    United Kingdom
    #8
    Working fine here... Although have noticed that, on occasion, I've opened a doc whether that be Excel or Word and the key strokes do not respond. But it's very intermittent and obviously something in the software, not hardware. A close and re-open of the doc resolves it.
     
  9. cranshinibon thread starter macrumors newbie

    Joined:
    Nov 5, 2014
    #9
    this worked....i don't know what caused it, but it worked. I didn't think upgrading would have caused an issue but the reinstall worked like a gem. thank you
     

Share This Page