Subler 'HD' issue with iPad

Discussion in 'Apple TV and Home Theater' started by iOrbit, Oct 29, 2012.

  1. iOrbit macrumors 6502a

    Joined:
    Mar 8, 2012
    #1
    for some reason, when i use subler to rate my film as '1080p HD' so itunes recognizes the file as a HD file, with the little 'HD' logo, it does not appear on my home sharing list of movies on my iPad.

    the same is not true for my Apple TV though, they still show up on the apple tv and i can still watch them, but NOT on the iPad, they disappear.

    anyone know why this is or how i can fix it?
     
  2. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #2
    I use Subler and just checked the iPad. The HD movies are all there.
     
  3. iOrbit, Oct 29, 2012
    Last edited: Oct 29, 2012

    iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #3
    dont understand what im doing wrong then.

    im using an iPad 2.

    appletv 3,

    and i use handbrake to convert a movie to m4v/mp4. then lastly i use metaz to tag and and give it the data and artwork.

    up to this point, they always worked with my ipad and showed.


    its when iv used subler after to specifically tag it as 1080p/Movie/Rated R etc that they arent viewable on the iPad.

    i dont know subler very well, could i be missing out a setting?

    ***EDIT****

    NVM, i believe i have solved the issue, thanks to this discussion here:

    http://forums.macrumors.com/showthread.php?t=1355198

    basically, iPad 2 doesn't support 1080p, which is BS because it played my 1080p videos pre-metadata input, just fine. simple:

    don't metadate your videos as '1080pHD' if you use an iPad 2 or any other device that doesn't 'support' 1080p HD. instead list it as 720p HD.. thats if you care to have itunes recognise your files as HD. otherwise don't bother at all.
     
  4. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #4
    I don't think that is it as the iPad 2 does support 1080p. And our files tagged as HD using Subler show up on our iPad.

    I noticed you said that you tagged the files with MetaZ then used Subler to change the HD tag. Have you tried just using Subler to add the metadata?
     
  5. ProudLoz macrumors regular

    Joined:
    Aug 26, 2012
    #5
    OP, On Subler try to change the profile of the H.264 video stream of your file from High 4.1 to either Main/High 3.1. I believe that should solve your problem. You should then be able to tag them as 1080p and enjoy them on your iPad 2.

    I had to do this one some of my iPad 3 encodes that went up to High Profile 5, and had to spoof it to High Profile 4.1. So I believe this could help you out.

    Also, you'll have to delete and readd the movie into the iTunes database. The profile of the H.264 encode will not change like metadata does when you do a "Get Info" refresh.
     
  6. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #6
    i just made all my 1080p files '720p' with subler, now all my movies appear on the iPad, so it solved it for me. i don't know why your 1080pHD files show, its either some setting in there somewhere or something to do with the below posters insight:

    thanks, im going to just stick with the 720p fix i'v done, itunes doesn't appear to state 1080/720 on the files unless you click get info, it still remains HD. so im content with that. my HD files are big, averaging 10gigs each.

    they are now all playing on my iPad now though!
     
  7. Menneisyys2 macrumors 603

    Joined:
    Jun 7, 2011
    #7
    The iPad 2 indeed didn't support 1080p before iOS 5 - back then, you couldn't synchronize 1080p videos to it. (However, via third-party players, you could still play 1080p videos.) Now (with iOS 5+) it does.

    I've given this issue a more thorough test and found out that:

    - the only difference between the iPad 2 and 3 (both on 5.1.1) is that the latter also lists (and plays back) High@4.2 1080p60 videos in my iTunes; the former doesn't.

    - Baseline@5.0 videos are also streamed to the iPad 2. (It seems the 4.1 threshold is only applied to synching but not streaming.)

    Will also try to check out the HB problem.
     

Share This Page