Submitting trouble

Discussion in 'iOS Programming' started by jessejohnson147, Apr 7, 2010.

  1. jessejohnson147 macrumors newbie

    Joined:
    Jun 5, 2009
    #1
    I am submitting a app and I keep getting this error:

    "The binary you uploaded was invalid. A pre-release beta version of the SDK was used to build the application."

    My xcode version is 3.2.2 and I tried building it about every way can someone please help? Thanks
     
  2. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #2
    Are you using the Final iPhone SDK 3.2 (Build 10M2148)? Apple may have already stopped allowing submissions from anything older.
     
  3. jessejohnson147 thread starter macrumors newbie

    Joined:
    Jun 5, 2009
    #3
    yes im using the 3.2 final version and building in 3.2
     
  4. LastLine macrumors 65816

    Joined:
    Aug 24, 2005
    #4
    I'm having this issue also. I previously had the 4.0 beta on my machine but have since wiped the whole root developer folder and the like and reinstalled to the 3.2.2/3.2 final release and rebuilt the app, yet it still says
    "The binary you uploaded was invalid. A pre-release beta version of the SDK was used to build the application."


    Anyone got any bright ideas? An Xcode plist somewhere perhaps?
     

Share This Page