Subs!!!!!

Discussion in 'Apple TV and Home Theater' started by eddtr1, Oct 22, 2010.

  1. eddtr1 macrumors newbie

    Joined:
    Jun 23, 2009
    #1
    How the heck do i get subs into a mp4 file!

    I have spent a fe months encoding my dvd collection to mp4 and then using iflicks to get the data all good.

    Now then - the bourne identity has a bit of german to it at the start. I have used handbrake to add subtitles but for the life of me i cannot get them to show

    Also lord of the rings - i handbraked both discs in the extended movie for the fellowship of the ring. I then joined the two files in visualhub but i still cant get the elvish to show!!

    any help please. Also i hear subtitles dont even show on apple tv.
     
  2. Kurgan macrumors newbie

    Joined:
    May 12, 2010
    #2
    Hi

    I have had a problems with this myself until i notised that most srt are encoded wrong. Make sure that the text file is UTF-8 (e.g. with notepad++) and choose UTF-8 as encoding when importing the srt into handbrake.
     
  3. eddtr1 thread starter macrumors newbie

    Joined:
    Jun 23, 2009
    #3
    but i am taking the subs of the dvd - or isnt that possible - all i want handbrake to do is encode the foreign spoken parts of films like the dvds seem to do automagically - is this too much to ask!
     
  4. NightStorm macrumors 68000

    Joined:
    Jan 26, 2006
    Location:
    Whitehouse, OH
    #4
    No, the foreign audio search and forced subtitle options located on the subtitle tab are exactly what you want. It won't work on your VisualHub-combined LOTR encodes as the subtitles are no longer part of the input.

    That said, you may want to update to the latest nightly build as I think there was an issue with this functionality in .9.4 that prevented it from working everytime.

    You should use something like DVDtoOneX to properly combine the two discs from each LOTR movie; this will retain chapter markers and subtitles properly.
     

Share This Page