substitute another font for arial

Discussion in 'Jailbreaks and iOS Hacks' started by The Admiral, Mar 2, 2009.

  1. The Admiral macrumors member

    The Admiral

    Joined:
    Mar 2, 2009
    #1
    i would like to replace the Arial fonts on my phone with Liberation Sans (which is metric-compatible, so any text intended to be set in Arial will flow the same way, as the glyphs are all the same size).

    what i tried first was simply replacing the .ttf files in /System/Library/Fonts/Cache, moving Arial.ttf, ArialBold.ttf and so forth out of the way and placing the corresponding Liberation files there, named Arial.ttf, ArialBold.ttf, etc. the result was that Safari simply fell back to Helvetica, which was an improvement, but is likely to break some layouts.

    i found FontSwap in Cydia, which was helpful for replacing the dreadfully illegible Marker Felt in the Notes app, but it doesn't appear to be capable of replacing individual font files on a global basis.

    is there a simple answer i'm not thinking of? or should i proceed immediately to the FontSwap source code?

    so, no ideas? anyone know where i can read some documentation about the font subsystem?
     
  2. The Admiral thread starter macrumors member

    The Admiral

    Joined:
    Mar 2, 2009
    #3
    yeah, that makes sense. i don't know why it didn't occur to me that the font names were stored in the TTF files. i'll build a version of Liberation Sans tonight that thinks it's called Arial and see how that works out.
     
  3. The Admiral thread starter macrumors member

    The Admiral

    Joined:
    Mar 2, 2009
    #4
    thanks, that did it. the files i built using the redhat Makefile and modified sfd files didn't work (and AAT just fell back to Helvetica)... but by copying the relevant metadata over using fontforge this is the result when i look at my test specimen:

    [​IMG]

    success!

    i've posted a zip of the files here, for anyone else who rages uncontrollably at the sight of arial:

    http://www.sendspace.com/file/9pm8vr
     
  4. Terance macrumors newbie

    Joined:
    Jul 29, 2008
    Location:
    St. Louis Area
    #5
    is there anyway you could put up a guide?

    I have been trying to use the font from bioshock to set as my system font and I just cannot do it.

    I opened file forge, tried to separate the font from the meta data and . . .I just cannot do it.


    It seems like something that should be so simple and easy, but it isn't :(
     
  5. The Admiral thread starter macrumors member

    The Admiral

    Joined:
    Mar 2, 2009
    #6
    i'm fixing a couple of things on my rifle at the moment but i will write up a guide later on with screenshots that covers the relevant metadata fields and how to copy them using fontforge. really this ought to be an easy process to automate, so depending on how much i can learn about fontforge i might be able to come up with a script to do it automatically.

    to make a long story short, just open up Element->Font Info* on both files, and copy and paste everything from the Names and PS UID pages from the original font file into the one you are modifying. you don't need to copy the copyright statement on the Names page, however.

    *well, at least that's what the menu entry is called on the version of fontforge that ubuntu ships. your mileage may vary.
     

Share This Page