Subtitles too small in iTunes

Discussion in 'Apple TV and Home Theater' started by kuwisdelu, Mar 17, 2011.

  1. kuwisdelu macrumors 65816

    Joined:
    Jan 13, 2008
    #1
    Those of you who use Subler to add .srt subtitles to your mp4's may remember a while back that there was some bug in iOS where the Apple TV 2 and the iPad rendered the subtitles way too small to read, and trying to change their size didn't work.

    I now have a similar problem, but for iTunes. I'm on a new 2011 MBP, and the only thing keeping it from being a great experience is the trouble I've been having with iTunes — problems that I didn't have on my old MacBook.

    Much like the iOS subtitle bug, iTunes on my new MBP isn't obeying Subler's subtitle size and offset, and as soon as I go fullscreen, they're way too small to read. For some reason, this is only happening on the new MBP, despite my MB and MBP both being on iTunes 10.2.1. I'm not sure if this is somehow related to the iOS 4.3 Home Sharing bug on the front page, but from my sample size of one it seems to be an iTunes bug that's only affecting the new MBP.

    I have a few mp4/m4v files for which iTunes is obeying Subler's subtitle size, but after examining every setting I can think of, I can't figure out what makes them different from the majority that don't. And all of them play properly in QT 7 Player and the way they always have QT X Player.

    I don't suppose anyone out there might have some ideas, or have run into this kind of problem before with subtitles in iTunes? :confused:
     
  2. lucidinferno macrumors newbie

    Joined:
    Mar 23, 2011
    #2
    I'm having the same problem. I've uninstalled and reinstalled iTunes, deleted all the plists, and still having problems. I can't bring up the subtitles on some, and the ones that do come up stay on permanently and are too small. Please help.
     
  3. kuwisdelu, Mar 23, 2011
    Last edited: Mar 23, 2011

    kuwisdelu thread starter macrumors 65816

    Joined:
    Jan 13, 2008
    #3
    The affected movies and TV shows also give me pixelated/blocky playback during certain scenes in iTunes. It has to be some iTunes issue, because they play exactly as they should in QT 7 Player. These all play fine on my old 2007 MacBook in iTunes.

    My current solution has just been to choose Show in Finder and play them from QT 7 or QT X. :(
     
  4. zoro5 macrumors newbie

    Joined:
    Mar 25, 2011
    #4
    Same thing is happening to me. Everything worked fine until yesterday. As posted above, all subtitles are OK in QuickTime X or 7 (even VLC works fine). The odd thing I noticed is, that on movies played previously the subtitles are stuck (in a very tiny font) and I can't switch them off. Movies that were not played at all or files I added today do not display any subs. When I click the subtitle track it jumps immediately back to off.
    I'm using iSubtitle, but I guess that is not the issue here since everything works fine in QT.
    BTW, exactly the same problem in iTunes for Windows (which I tried out of desperation about an hour ago) :(
     
  5. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #5
    Starting in 10.6.7, iTunes uses a AVFoundation to play movies instead of QuickTime, so there are some new bugs. :(
     

Share This Page