Success! 3.1.3 => 3.1.2

Discussion in 'Jailbreaks and iOS Hacks' started by Tensakun, Feb 18, 2010.

  1. Tensakun macrumors 6502

    Tensakun

    Joined:
    Jan 21, 2008
    Location:
    Akashi, Japan
    #1
    First of all, don't want to raise the hopes of 3Gs/late model owners who do NOT have their SHSH files saved on Saurik's Cydia server -- such a downgrade is probably not possible now, doing it would earn you the MacRumors Hacking Nobel.

    But I'm not starting a new thread (just) to toot my own horn either; rather here's something to seriously consider--you may have saved your files at Cydia and completely forgot about it. Taking the few minutes to go thru this simple procedure can save you hours of fretfully pouring over websites and trying desperate, wildass strategies.

    I'm sure that when I did press the "make my life easier" button I just thot, "why the hell not?" and completely forgot about this--in my case dumb luck and not 'foresight' at all! Aside from singing "oh happy days!" I kicked myself for not doing this at first and saving a few evenings of futile effort past 3 AM.

    After successfully reloading 3.1.2 (went thru the restore process thrice for good measure), I predictably got the infamous 1015 error; as mentioned in this forum, this does NOT mean the restore failed, just that Apple is confused by a diff in OS and firmware versions. Used redsnow's "only boot tethered right now" option and escaped recovery mode--there are probably simpler methods to do this, but it worked.

    Then even after restoring the settings from my iPhone, got no service (Softbank). Bit of a panic, wondering if the ipsw file I used for restoring couldn't link to Softbank; then stumbled across the fact that in the iTunes restore window, in addition to just restoring to the generic backup of your phone, you can use that button as a dropdown menu to find previous backups (see attached graphic). So I went to the most recent backup BEFORE all of my monkeying around with downgrading attempts and voila, phone service back just fine.

    So two lessons learned:
    1) NEVER accept Apple's kind invitation to 'upgrade' your phone OS until you've looked over this forum and are sure a jailbreak is possible.
    2) Make a conscious effort to store your settings on Cydia, even if you never use a Cydia app.

    Good luck in regaining some control over your own expensive phone!
     

    Attached Files:

  2. chinaman87 macrumors newbie

    Joined:
    Feb 17, 2010
    #2
    well I synced my old 2g iphone with itunes and it was on 3.0. I now have a 3g iphone and it is on 3.1.3 and I'm trying the backup restore method, I hope I get through it without any problems. I'm wondering if it'll even work
     
  3. chinaman87 macrumors newbie

    Joined:
    Feb 17, 2010
    #3
    yeah that didn't work for me, then again I probably didn't back up in cydia , SOL for me
     
  4. chinaman87 macrumors newbie

    Joined:
    Feb 17, 2010
    #4
    yeah that didn't work for me, then again I probably didn't back up in cydia , SOL for me.

    whoops double post
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    3G phones do not need SHSH files.

    A 3G can be upgraded and downgraded at will and jailbroken to any firmware

    Go to iClarified and get a tutorial to JB a 3G for whatever OS you have (Mac or PC)
     
  6. g2tegg macrumors member

    Joined:
    Sep 5, 2008
    #6
    Interesting!! I just successfully downgraded to 3.1.2 from 3.1.3 as well and also got the infamous error 1015. What that pretty much means is that the iPhone is stuck on recovery mode loop.
    The way I fixed it was through iRecovery, which is very easy to use if you know how to get around on CommandPrompt/Terminal.
    Link for download (Download iRecovery AND libusb. Install libusb first)
    http://www.ihackintosh.com/2009/07/irecovery-iphone-recovery-mode-loop-restart/

    If your having problems using CommandPrompt (or your too young to even know what it is haha) here is a tutorial for you (Windows):
    http://www.ipodtouchfans.com/forums/showthread.php?t=137021

    Sorry for thread jacking here Tensakun I just thought I would share. Your method may be easier, I really dont know because I never tried it. But at least other fellow users here have more then one option, if one should fail.
     
  7. chinaman87 macrumors newbie

    Joined:
    Feb 17, 2010
    #7
    gotcha thanks
     
  8. chinaman87 macrumors newbie

    Joined:
    Feb 17, 2010
    #8
    I got the 1015 error then I tried dling lin win 32 and irecovery . I tried opening irecovery but it didn't do anything.. so now I just restored back to 3.1.2. and stuck the connect to itunes logo..
     
  9. g2tegg macrumors member

    Joined:
    Sep 5, 2008
    #9
    Which means your phone is stuck in dfu loop. Are you double clicking on iRecovery or using command prompt? Read the tutorial I posted again. Its pretty straight forward
     

Share This Page