Success! Fixed my HP and Cannon scanner problems under Lion

Discussion in 'macOS' started by sjinsjca, Aug 13, 2011.

  1. sjinsjca, Aug 13, 2011
    Last edited: Aug 13, 2011

    sjinsjca macrumors 68020


    Oct 30, 2008
    Within a couple days of OS X Lion's release, I purchased it, performing a clean-install on a new hard disk for my early-2010 MacBook Pro (2.66GHz, 8GB RAM), then restored from my old disk. The process was painless, and I went about my days of pounding the living heck out of the poor beast, running huge virtual machines, working on development work, multitasking insanely, etc. Throughout, Lion has impressed me with its stability and many subtle advancements. This is no cosmetic upgrade.

    But along the way I noticed my HP 7400 Series multifunction machine (7410xi, specifically) would no longer scan. Googling revealed many, many other unfortunates with the same issue. Two printer updates arrived from Apple, and no joy. Even in the Print & Scan Preference Pane, the scan functionality did not appear. The Scan tab was missing entirely!

    Things that did not work included:

    • Attempting to search-for and install the scanner as a separate device. Such a device simply would not appear.
    • Resetting the printer system. This involves command-clicking on the printer in the Print and Scan preference pane; it deletes all your printers. You then reinstall them. No joy; the pane still did not see a scanner (the Scan tab was still missing), nor did Preview or Image Capture.
    • Doing it all in an Administrator account. No difference.
    • HP's website. Nary a mention of OS X 10.7 Lion. And legions of reports from folks complaining of missing scanners even from freshly purchased machines. This is the third strike for HP as far as I'm concerned: after Snow Leopard was introduced, they initially would not support this and other older printers (and this one isn't that old), even "suggesting" that their customers should buy new printers. Then they grudgingly coughed up a driver update but removed the OCR functionality that came with the machine. Phooey!

    The machine was almost out of ink anyway, and I noticed a Canon Pixma MX882 on sale at Costco for about the same cost as a set of cartridges for the HP. A quick perusal of user reviews on my iPhone suggested it was a good machine. I decided to relegate the HP to fax duty and replace it with the Canon.

    So I brought the Canon home. It's a bit involved to set up, with a separate printhead that needs careful installation, and a head-alignment process that, while automatic like the HP's, requires a special piece of paper for the process. They provide two of the pieces of that paper, so I'll have to store the spare carefully. (Alignment is only required when the head is replaced, not the cartridges, fortunately.) The Canon has an odd and IMHO somewhat ill-considered user interface based on an array of dynamically labeled buttons to the left of a color LCD. It took a while to get used to, and entering a long WAP2 password is annoying, but it all went smoothly enough.

    In the end, there were no problems, so I turned to my Mac and--since installation CDs are not supposed to be required--had the Print & Scan preference pane search-for and add the new printer.

    And. It. Came. Up. With. No. Scan. Tab.



    It took me a while to draw a parallel this behavior with the identical behavior of the HP. In the mean time I went googling again and found that Canon, laudably, has a section of its website devoted to Lion. Way to go, Canon! Unfortunately it's not well organized. There are, for example, four disk images to download just from the "Drivers" section, but no clue which does what, or in what order you should install them, or which constitutes an update to which. Plus, once the disk images are mounted, the disk names bear no relation to the original download titles. Download 'em all, and you'll be more confused than ever.

    Next came a couple hours of trying this-and-that with no success. Finally, dreading the experience, I called Canon and waded through their voice-prompt menu, expecting a long wait on hold to be connected to a script-reading troll in Bangalore. To my delight I was immediately connected to a helpful gentleman with a pleasant Southern accent, substantial Mac-domain knowledge and boundless patience. Together we downloaded several of the items and reinstalled them, then verified that the unit could scan using Canon's own scanning utility. But the scanner would not show up in the Print & Scan preference pane, Preview or Image Capture. And no scan tab in Print & Scan.

    He regretfully informed me that the behavior was anomalous and reflected an issue with OS X on my machine. This wasn't what I wanted to hear, but by then it was believable. He suggested doing a permissions repair; alas, this had no affect.

    Acid test: I switched to my wife's untouched OS X Lion MacBook Pro. Went to Print & Scan. Clicked the "+" button. It found the Canon, and installed it, and lo: there were the missing Scan and Print tabs!

    Her machine:

    And so, with no further tricks to try, and possessing a fresh backup from the previous night, and with the fault clearly my machine's, I reset the printer system one last time, then rebooted, holding down command-R to boot into Lion's recovery partition. (Note that if you have FileVault enabled, holding the Option key does nothing; it must be command-R).

    The process took several hours and seems to download a fresh copy of Lion. It concludes with the machine turning itself off. Rebooting reveals all your files, software and user accounts intact (but some things such as Java and Silverlight will need to be downloaded freshly... typically, this is automatic when you run something that requires them for the first time). Spotlight will take a while to index your disk again, too. But the machine is fully freshened in-place, and if my experience is typical, you won't need that Time Machine backup.



    Both the Canon and the old HP installed with Scan-tabs flying! Preview and Image Capture both see the scanners now.

    All is copacetic.

    Lessons learned:

    • Even OS X Lion can get corrupted. In my case, OS-abuse is part of my daily routine, so that's one possible cause. It is also possible that my Lion installation was faulty from the start.
    • Lion's restore functionality fixed everything. And its download-on-demand approach to installing printer drivers does work, and you don't need (and probably shouldn't even try) the CDs and downloads from the printer manufacturer.
    • Canon's support is terrific, and their commitment to supporting the Mac is palpable. Top grades for Canon!

  2. Jack MacD macrumors newbie

    Jul 25, 2011
    You never explained if all the driver software, four parts, were needed. just the most recent?
  3. sjinsjca thread starter macrumors 68020


    Oct 30, 2008
    None of the software from Canon's site was needed, as it turned out.

    OS X has everything built-in to support this printer. That was the cases with my wife's MBP, and with my own once I got Lion refreshed.
  4. darster, Sep 16, 2011
    Last edited: Sep 16, 2011

    darster Suspended

    Aug 25, 2011
    I had problems with my canon mp620 not being able to scan. I downloaded new drivers but could still not scan. In the end, the only way to get it to work was to go into ~/Library/Printers and delete all directories labelled Canon. Emptied trash, and rebooted. Then I went back to the Canon site and downloaded all the correct drivers, selected printer in Lion, and voila, print and scan worked. However, in systems preferences, in Print and Scan, it doesn't have the Print Scan tab like the example shows. However, when I click scan on the printer itself, it it scans right to my iMac.
  5. sjinsjca thread starter macrumors 68020


    Oct 30, 2008
    I suspect that's /Library/Printers, without the tilde (which substitutes for your username).
  6. sjinsjca thread starter macrumors 68020


    Oct 30, 2008
    Update: It happened again

    Something about Lion's printing/scanning system is fragile, as the scan tab for my networked Canon printer disappeared AGAIN from my system, as did the entire printer entry for the HP multifunction printer also on my network.

    As before, the scanner could not be found in Preview, either.

    As before, resetting the printer system (control-click on the printer listings in System Preference's Print/Scan pane) and reinstalling the printers did not help. (Intriguingly, finding the Canon took a long time at the beginning of the reinstall process. See note further on.)

    I tried removing the Canon and HP folders in /Library/Printers as suggested by darster a couple posts ago. On my system that resulted in the printers being not-findable at all when I attempted to reinstall. I went to and waded through the support pages to find the download for my Canon printer, and downloaded the driver. This allowed the printer to be reinstalled... and it was still missing the scan tab!

    Out of ideas, I rebooted into the recovery partition by holding down command-R, and reinstalled Lion again, as I'd done before. This took a couple hours but retained all my files and programs. Annnd: it fixed the issue. Clicking the "+" to add a printer NOW resulted in an instantaneous list of found printers that included both the Canon and HP. No more long-term wait.

    I installed both (which triggered some downloads). No problems. And the scan tabs are there, and Preview sees both units' scanners.

    So all is fine now, but: WHY?
  7. sjinsjca thread starter macrumors 68020


    Oct 30, 2008
    And ANOTHER update: It happened AGAIN!

    It's been just a few days since I posted on this thread that my missing-scanner-tab issue had recurred, and that reinstalling Lion fixed it.

    Well. It happened again. This time the sequence was:

    1. Couldn't print. Mac said both my printers were offline.
    2. Reset printer system. Attempted to reinstall. Took a long time for the system to find the printers. (It found them shared on my wife's Mac instantly.)
    3. Installed the printers. Both came up with no scan tab!

    Getting a little disgusted, I rebooted into the Recovery partition and told it to reinstall OS X Lion. It started... and said it would take 99 hours and 19 minutes. There was no indication downloading was proceeding.

    I had stuff to do, so after a few minutes of seeming inactivity I cancelled and rebooted.

    And: I noticed that Spotlight was re-indexing. Hm... my abortive attempt at reinstalling seemed to have reset the Spotlight index.

    On a hunch, I went back into Systems Preferences and tried reinstalling my printers.

    It worked! Both were found instantly and reinstalled without issue, with Scan tabs flying.

  8. Capex macrumors regular

    Aug 31, 2010
    I don't know if this works for everyone, but I have always been able to scan via Image Capture.

    Edit: Maybe I should read more. I apologize.
  9. daveinburrridge macrumors newbie

    Nov 24, 2011
    Canon MX870 Scanner Communication Failure and OS X 10.7.2

    sjinsjca helped greatly. My MacBook Air under OS X 10.7.2 exhibited the same problem with the Canon MX870 wirelessly connected. Printing worked fine. Scanner could not be found. The Scan tab was not seen.
    I used the following event sequence to obtain both Printer and Scanner functions with the MX870.
    1. Reinstall Mac OS X using OS X Lion Recovery. Restart holding down Command and R key.
    2. Power off the MX870.
    3. Reset the Printer System (Control click on the printer listing in System Preferences Print/Scan pane.)
    4. Power up the MX870.
    5. In the System Preferences Print/Scan pane, add (using +) a device. The Scanner will first be found.
    6. In the System Preferences Print/Scan pane, add (using +) a device. This time the printer will be found.
    7. Lock the pane.
    The Print/Scan pane still does not show a Scan tab, but the Printer and Scanner headings appear with the "Canon MX870 series ..." listed below each.

    Attached Files:

  10. jiazzi macrumors newbie

    Apr 21, 2012
    Whoa Dave - We work at the same place!

    I know this is off topic but couldn't help it when I saw the images he posted. It looked so familiar and when I enlarged the image - it turns out it's the same place I work at! What a small world!

    On topic...kind of...the wireless scanning function doesn't work on my leopard (yes it's old i know) although the printer recognizes my computer. If anyone knows, please email me or PM me please. Thank you.

  11. ebuh macrumors newbie

    Jul 13, 2012

    1. Was the printer/scanner working fine earlier?
    2. Did you make any changes to the computer prior to the issue?

    I would suggest you to uninstall the drivers completely from the computer.
    Then download and install the drivers from the following links:

    Method 1:

    Method 2:
    Canon PIXMA MX882 Driver
  12. qtrim macrumors regular


    Oct 7, 2011
    ML 10.8.2 update also contained an update for Canon Printers and Scanners that fixed my scanning issues. Nothing else had provided a permanent fix, this update did, so it was an Apple problem.
  13. Zalia macrumors newbie

    Jun 8, 2010
    Fixed! Scanner now picking up Mac

    After upgrading to Mountain Lion my scanner wasn't picking up my Mac, however, I could scan using MP Navigator from my mac, but prefer doing it on the Canon printer/scanner (MP640).

    I went to, selected my operating system (Mac OS X v10.8) and then downloaded and installed the MP scanner driver (MP640 series Scanner Driver Ver. 15.5.2a) which worked. My mac now shows up in the window on the Canon printer.

    Hope this helps.
  14. troutman41 macrumors newbie

    Sep 9, 2013
    Lost scan tab on Print&Scan osx 10.8.4

    My macbook pro with Mountain lion 10.8.4 connected via wifi to the router would not connect to the scanner section of a network connected Brother mfc7440n multifunction printer/scanner/fax. Printing was fine just the scan was not working. The system preferences, Print and Scan was missing the scan tab.
    Connecting the macbook to the lan/router with a cat5 cable instead of wifi resulted in the scan tab appearing in Print and Scan. Scanning worked with the direct cable but not with wifi.
    Did a re-install of Mountain Lion but it was only finally fixed when I rebooted the router!

    Save yourself a lot of grief! Connect with a cat 5 cable and reboot everything that connects you to the internet before you waste time doing a re-install.

Share This Page